🇺🇦 We stand with Ukraine! 🇺🇦

How do I add PrusaSlicer into Octoprint?

The main question is why? You're losing most of the functionality of a slicer by putting it into OctoPrint.

I at least want to have some sort of 'cloud' slicer because I'm often hoping between different computers (and each computer has different settings because I change one setting on one computer but forget to change the same setting on the other). That's mainly why I thought having a slicer already in Octoprint would solve this because I've heard people adding a slicer to Octoprint and no longer needed to depend on the desktop slicers

Geared towards the palette and palette 2 but can be used as just a single material slicer. Does a pretty good job of it too.

Just found this article and am going to run through the steps to see if I can get it to compile. Seems like the trick is compiling the boost library from source.

Huh, it actually seemed to have compiled with cmake this time. I used the command cmake .. -DSLIC3R_WX_STABLE=1 and I didn't get an error that time. I'm still waiting around for make -j4 to finish

1 Like

SliceCrafter (Online ICEsl)

Haven't finished the compile of libboost yet, but reading through you may want to use the command cmake -DSLIC3R_GUI=OFF and it will make a CLI only version of the executable.

While this might make it "work", IMO it won't make it "useful".

Personally I agree, slicing on a pi seems like it wouldn't be efficient. You definitely wouldn't want to slice while printing, but just trying to help out the community for those that do want that feature. From the PrusSlicer issues linked above it seems 2.0 is more efficient than previous versions.

Ok.. how do I test to see if it works? Since it doesnt need perl, I can't run ./slic3r.pl --help

I'd guess the make file put a binary executable somewhere (may have to chmod +x)

How do I run chmod +x?

You ssh to your pi and cd into the folder where the file was created, I think the file is named prusa-slicer based on the releases on their github. I couldn't ever get it to build on mine. Then you run the command sudo chmod +x prusa-slicer of course replacing the name with the name of the file that was actually built.

In order to get "cloud" functionality I did this:

  1. Make a folder in Dropbox called "PrusaSlicer App Profiles"
  2. Launch PrusaSlicer with the option --datadir ~/Dropbox/PrusaSlicer\ App\ Profiles

I went a step further and made a launcher for Mac that does this for me AND backup the current profiles in PrusaSlicer App Profiles _Backups
A link and discussion can be found here

Hope this helps.

1 Like

I actually don't have Dropbox, but would Mega/Google Drive work?

Google Drive should work. Just adjust the path accordingly. This will allow you to take your latest profiles anywhere so you can slice on any computer.

I know it's not what you were looking for but as others have stated the Pi is simply not powerful enough. Slices would take far longer AND worse it would interrupt a print if you tried to slice a complex model while printing.

I can't get the program to launch anymore. I added the option in the target option in my shortcut:

"C:\Program Files\Prusa3D\PrusaSlicer\prusa-slicer.exe" --datadir=C:\Users\myname\Google Drive\3D Printing\PrusaSlicer\

Looks like you have spaces in the data directory's path. You'd need to surround that by double quotes.

This is what the executable now sees as command-line arguments:

0) "C:\Program Files\Prusa3D\PrusaSlicer\prusa-slicer.exe"
1)  --datadir=C:\Users\myname\Google
2)  Drive\3D
3)  Printing\PrusaSlicer\
1 Like

I got it working. Thanks guys!

1 Like

I think your looking for this as was i. Took a while to find it.