How do I add PrusaSlicer into Octoprint?

I've tried the Slicer plugin but I can never get it to compile and the current version of PrusaSlicer I'm using is completely incompatible with the version that the plugin supports. Is there any other way to add the slicer to Octoprint?

1 Like

Usually, you put the API and the OctoPrint IP to PrusaSlicer.

I mean, how do I put it into Octoprint itself? Like have it acutally integrated into Octoprint without having to use the desktop Prusa Slicer

1 Like

I see.
I'm afraid there is no chance.
The last slicer included to OctoPrint was the Cura Engine - and this was omitted with the recent version of OctoPrint.

But can't you download Cura Engine?

There is a plugin for that: CuraEngine Legacy

Does it work with PrusaSlicer?

No, that is a slicer on it's own.

Could you please explain what you like to attempt?

I want to add in PrusaSlicer into Octoprint/Octopi so I don't have to depend on the desktop PrusaSlicer.

There is a Linux version of PrusaSlicer, if it would run on a RasPi, it would be a separate application, not a plugin

Is there anyway I can install it?? I've been trying to set it up with this plugin but I've having many issues getting it to compile with cmake

You may ask the plugin author. He maybe can help.

I don't believe you will be successful getting PrusaSlicer to run as a standalone application on a Raspberry Pi, it just doesn't have the "horsepower". In particular, 1GB of physical memory.

I'd start by asking in the Prusa Forum for advice on how to build a Raspberry Pi version.

I cant ask the author, he pretty much said he wasnt going to respond to anyone asking for help since he left the community

Bad that... :worried:

You're following the instructions here?

I did, but it keeps on giving me an error when running sudo make -j2

What is the error? I haven't tried myself but can test it. Based on the previously linked instructions it looks like what that plugin is interpretting as "latest" is not the PrusaSlicer version but the previous Slic3r PE version as there are references to PERL which is no longer used in PrusaSlicer. Maybe you could look into the build instructions over here.

Here's the issue I posted when trying to get 1.43.13:

But it's much pretty much the same issue I've been having for the longest with this plugin+

Still getting the compile errors with the PrusaSlicer link you sent:

CMakeError.log (3.3 KB)