How to modify configure.yaml to use octoprint sound plugin

Good afternoon. I’ve been wanting to use a plug in to run custom sounds over my octoprint raspberry pi4’s speakers

Here’s the plugin in question.

Here’s the thing, it installed alright but I need to modify my config.yaml to add this to it.

I have a feeling the lack of this info is preventing my speaker from playing the sounds properly.

night_start: 20
night_end: 6
night_volume: 60
- change
- offset
- save_offset
- baby_up
- baby_down

I don’t have a display on this device but I can ssh into it.

I’ve also looked at the sd card and couldn’t find the config.yaml

Does anyone have a effective method of adding this section to my config?

config.yaml on an octopi image can be edited with the command below.

nano ~/.octoprint/config.yaml

Thanks allot! Now since I’m still a little new to this command. I’ve hit y to save but it’s thrown a buncha of options at me I’m a little less than familiar with.

This includes stuff like help, cancel, dos Format,Mac format, append, prepend, backup file, and browse

How do I confirm my changes?

Sorry, should have included that. ctrl+s to save ctrl+x to exit.

Seems to have saved. Still having some trouble though. It says it’s playing the Printing.mp3 in the terminal but I’m not actually getting sound.

I have a guess to it though…

It’s looking for files in .octoprint/data/sound is that data folder actually hidden?

I had made a data and sound folder via creating the folders in windows but I’m not sure if it’s actually the folder it’s looking for.

the decimal point at the beginning of the filename in linux does make the folder hidden. you can use filezilla client to connect sftp to your pi and you'll be able to see them though and that will allow you to upload your files to the required path.

also, make sure you restarted OctoPrint after updating the config.yaml file manually to insure that the updated settings were saved.

I tried to give FileZilla a download but it seems windows defender isn’t having it. It’s instantly deleting it the moment it downloads.

Any workarounds or alternative methods?

you were downloading this one?

other alternatives would be winscp.

Yes I was using that one. Seems winscp will download Without defender trying to obliterate it though.

weird, never had issues before with downloading filezilla.

Super weird. I did get win scp to add the files though.

Here’s the thing. I’ve slammed into a brick wall. Even after getting the files added. I think this addons broken and without hope of an update either.

I’ve done everything correctly but it just won’t play audio through the speaker.

Audio tests work too so it’s not a speaker side issue.

I’d look elsewhere but
There’s just no working alternative addons for getting octoprint to play mp3 sound when preforming m300.
At this point in time.

Even m117 speech synthesis seems to be a nonfunctional addon.

Gah- sorry for taking up so much of your time.
At least I’ve learned a few things along the way like adding files via winscp and gaining better knowledge of certain commands over ssh.

I thought the name looked familiar. I assume you tried my last post in that issue for installing espeak and libespeak1 without errors? Do you happen to have any errors in octoprint.log for the plugin?

I haven’t given it a try considering my octoprint decided to have unrelated issues between now and then that required re-flashing but I’ll give it a try and see if my luck improves.