🇺🇦 We stand with Ukraine! 🇺🇦

I can not Enable Custom Image Preferences please help me.

Hello,
I installed Octolapse on my PI and I had a problem with the light flickering.
After searching, I realized a problem with the settings, but I could not open them.
I followed what needed to be done but it still did not open ...
(Troubleshooting · FormerLurker/Octolapse Wiki · GitHub)
I did step by step according to what is written and still it does not work ...
V0.4 Configuring a Raspberry Pi Camera · FormerLurker/Octolapse Wiki · GitHub

The camera test works but when I click on Activate Custom Image Preferences
I get this error:
Unable To Enable Custom Preferences
An unexpected error was raised while testing custom image preferences for the 'Webcam - Default OctoPi 0.16.0' camera profile.

I use a PI V2 camera
please help me ;(

I finally succeeded but got stuck in the initial problem ... light flickering

If anyone can help me fix this I would love to

flickering in the timelapse or in the liveview stream?

in the timelapse only

It's probably all the automatic correction stuff like white balance or brightness control.
If it those settings are changed all the time it seems like it's flickering.

You can disable those automatic settings and set static values with this plugin.

You need to slightly change something in the octopi.txt for the plugin to work.
Either put the sd card in your pcs cardreader or edit it via ssh

Here's a guide

I'm already done these things to run the Custom Image Preferences

I will now try to change the settings

@PrintedWeezl
These are my settings:

Did I miss something?
I still have the problem with the light flickering.

Could you upload a timelapse?

https://drive.google.com/file/d/1-usrxT1IjKY-YIDPcvgsHcLPcegFE9pA/view?usp=sharing

You may want to try the 'Powerline frequency' setting. Otherwise there may not be much you can do if it's the actual lighting from this side. If the lighting itself is varying, you'll need to try to stabilize it if possible.

To what value would you recommend changing the setting?

If I replace a lamp can it help?
If so how to choose a good one?

The value depends on the frequency that is used in your location.

If you use a DC powered LED lighting with a good PSU that would help the best.

I use an LED lamp
Of 220V I changed the frequency hope it will help ...

No, it still has the same problem ...
Only in Timelaps in the preview I not see it ...

Mains powered LEDs usually are not that well filtered on the DC side and still can cause flickering.

Can I buy 220V lamps that will come filtered?
How to know?

Usually not. They would be quite expensive due to the addition electronic parts

But how do you know they have a filter?
And maybe if I use regular bulbs it will help?

Usually not. AFAIK, they are not produced.

An incandescent light bulb would help quite a portion.

An alternative would be a small PSU with 12V 1A and with that 12V LEDs.
12W would be enough for a printer lighting.

I'll try to buy some bulbs tomorrow.
Could it still be a camera problem?
I tried to check with my phone and there were no problems ...