I need help configuring SIO Control

I need help to configure SIO Control on an Arduino nano, I loaded the firmware but I don't know if it is correct, and it doesn't work at all, when I try to turn on some pin nothing happens and the button in Octoprint doesn't change state

1 Like

Hi :tentacle:
Just show us what you did so far :slight_smile:

I loaded the SIO_Nano_Base firmware on an Arduino nano, and installed the plugin, as well as configured the pins within the plugin, however when I click on the button to turn on the desired pin absolutely nothing happens, not even the state changes button inside octoprint.

Is the interface showing that you are connected. Or is there another message showing?
A screen shot if the Communications tab would be helpful.

You can also turn on debugging for the SIO control and send us that log.
The normal Octoprint log will also have any errors or warnings that are being produced. If you don't know how to turn on the SIOC debugging log, you should send us that first.

You can also verify that the firmware is generally installed and working if you just open the Arduino IDE comm port and monitor it for just a few seconds.

On reset you will get this(the nanno will do this on connect):

DG:NanoSerialIO 1.0.6
DG:< Types
DG:tmpCS: 1031
DG:!:Using IO defaults1031
DG:< Set IO
DG:> Types

If you issue a command in the serial window, you can manipulate the IO directly there.

IO 17 1

That will turn on the output on Pin 24 / A5
and your serial output will change to match


Checking this could help you figure out if your issue is in the connection from Octoprint or if your Nanno is just not working as you expect. If the above does not work, you have some kind of Firmware or hardware issue with your nanno.

1 Like

I'll try this way, thanks

1 Like

Apologies for the case, English is not my native language and it is a bit difficult for me

The IO # command that is sent to the Arduino through the serial monitor only works with the analog pins (A0, A1, A2...)?

In the default config, they are the ones that are configured as outputs so that would make sense. If you connect the other pins to a 5v + you should see it report the input change in a similar way.

Hello, first of all I apologize, my language is Spanish, I will use the translator.
Something very similar happens to me, the buttons do not change state (I am using arduino nano with sio_nano_base).
Once the server has started, I must press the reset button on the Arduino and it starts working perfectly. What could be the problem?

1 Like

I lowered the serial communication speed to 9600 (I changed it in the code), performed the tests that you recommended and it works correctly.
However, in Octoprint it says that the device is connected, but it does not change its status.

When you restart the arduino, does the program work correctly and do the buttons change state?

Exactly, I turn on the computer, the server starts and connects to the Arduino but the buttons do not respond until I reset the Arduino. I already tried with a NANO and with a UNO it already does the same. I am using: PIN A0 PSU to turn the printer on and off and PIN A1 to turn on some LEDs.
The PSU button changes color and the server screen shows PSU on _PSU off but does not change state.

I'm going to try lowering the communication speed to 9600

I would not expect the baud rate to matter much but what might be happening is that the slower baud will cause some slower responses for the first few transactions. One of the things that is checked on connection from OctoPrint is if the firmware is compatible. That might be where you are having the issue now. The Nanno does something strange when you connect it to the PC. It restarts. And that is a bit of an issue because it could be that OctoPrint is sending the check command while it is still booting and the buffer might not get the data.

I would suggest that if you are still having issues. Providing the Octoprint log file or a debug log file for the SIO control PlugIn would be helpful for me to figure out where you are having issues.

I already tried with 9600 and it does the same. How should I send you the log file you mention?

You can post them here.

Ok but I don't know where to find it, sorry for my ignorance.

Regarding the communication speed, I lowered it because when performing the tests that you recommended (IO 17 1) the arduino did not respond well, I did not mention that I have a generic version of arduino, and with high speeds it generates problems, but when I lowered it it worked as expected. Apart from that, the error that arose later was that octoprint does not change the status of the buttons even if it is connected.

Best to just follow the process to get the system bundle.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

If we don't see any errors or indicators of what the issue is in the main log, I can help you turn on the PlugIn debug logging as a next step.