Installation problems

Good afternoon.
I installed Octoprint from Source on Orange pi PC. But after trying to start the server, I get an error like this:

pkg_resources.DistributionNotFound: The 'markdown<3.2,>=3.1' distribution was not found and is required by OctoPrint

Just an idea - try

pip install 'markdown==3.1'

Unfortunately, this did not bring any solutions.

Well I'm tagging @foosel - maybe she can help us :wink:

As far as I understand, the problem is that the new Octoprint version works on Python 3.8

The solution seems to be found on
But I do not know how to implement this patch.

After installation
cd ~
git clone
cd OctoPrint
virtualenv venv
./venv/bin/python install
The message appears:
AttributeError: 'module' object has no attribute 'version'

@Ivan_Goryaschenko you forgot to activate the venv in your shell. I would also be specific about which python version being used to create the venv (substitute with your version).

cd ~
git clone
cd OctoPrint
python3.7 -m virtualenv venv
source ./venv/bin/activate
./venv/bin/python install

You might also need other system deps such as python headers. That can be resolved with your distros package manager.

1 Like

I use the command
sudo apt-get install git python-pip python-dev python-setuptools psmisc virtualenv
to install Python.
As far as I understand, version 2.7 is installed

You can use python 2.7 or 3. What was the result of my last reply?

1 Like

No. It can support Python 3.7+ now but in no way does it need Python 3, it still works just fine under Python 2.

I would really like to know what makes people think that "now also supports Python 3" means "no longer supports Python 2". I never said anything and in fact have always underlined that the goal with 1.4.0 was to support both.

1 Like

Because people have been burned so often with the Kivy approach: "f#$!-it, we're on Py3 now so Py2 is no longer supported".

I'm pretty sure that next to no one who so far came in here with that weird assumption even knows what Kivy is.

And I'm sure they're happier people for not knowing Kivy.

octoprint@orangepipc:~/OctoPrint$ python3.7 -m virtualenv venv
/usr/local/bin/python3.7: No module named virtualenv

Then the python 3 dependencies aren't installed by your package manager. python --version (outside of the venv) will show you the default py version of your system. Use that version or install the dependencies for the version you want if they are available.

Thanks. I will try. I'll start all over again.

I apologize. I honestly try to figure out linux only only from last week, so a lot is still not clear to me.

In that case using an RPi with the preconfigured OctoPi image would definitely safe you a lot of frustration. As things are you are doing it hard mode.

I understand. But I have an Orange Pi PC and so far I can only have its functionality. I honestly did not understand at what point everything stopped working for me, because with previous installations everything worked well.

In general, I tried to solve the problem with the method described above, but nothing worked. But! This topic helped me Setting up OctoPrint on a Raspberry Pi running Raspbian.

I just entered the actual version of Octoprint manually and it worked.