Last update Octoprint (1.3.12 to 1.4.0)

I got error
"rm-linux-gnueabihf-gcc: internal compiler error: Segmentation fault (program as)"
and others:

sorry for pasting a window output,
plugin_softwareupdate_console.log (24.0 KB)


2020-03-05 16:20:26,548 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2020-03-05 16:22:23,158 - octoprint.plugins.softwareupdate - INFO - Starting update of octoprint to 1.4.0...
2020-03-05 16:25:13,559 - octoprint.plugins.softwareupdate - ERROR - Update of octoprint can not be performed, please also check plugin_softwareupdate_console.log for possible causes of this
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/softwareupdate/", line 987, in _perform_update
    update_result = updater.perform_update(target, populated_check, target_version, log_cb=self._log, online=online)
  File "/home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/softwareupdate/updaters/", line 116, in perform_update
    raise exceptions.UpdateError("Error while executing pip install", (stdout, stderr))
2020-03-05 16:35:26,552 - octoprint.server.heartbeat - INFO - Server heartbeat <3 
1 Like

Hello @Mariusz!
Could you please format the log with </> (in the toolbar of the editor here) or just upload the file?

Yeah please upload the file.
It's all in one line :slight_smile:

It's having a really hard time building psutil.

2020-03-05 16:25:13,545 ! error: command 'arm-linux-gnueabihf-gcc' failed with exit status 4
2020-03-05 16:25:13,546 ! ----------------------------------------
2020-03-05 16:25:13,546 ! ERROR: Command errored out with exit status 1: /home/pi/oprint/bin/python -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-L5wV40/psutil/'"'"'; __file__='"'"'/tmp/pip-install-L5wV40/psutil/'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-m0ylvi/install-record.txt --single-version-externally-managed --compile --install-headers /home/pi/oprint/include/site/python2.7/psutil Check the logs for full command output.
2020-03-05 16:25:13,549 > Running install for psutil: finished with status 'error'

Here was the attempt (assuming that this temporary folder still exists)

cd /tmp/pip-install-L5wV40/psutil/
ls -l

Interesting, it's trying to use the assembly language compiler for this. Is this the part where we fast-forward and you're running this on a Raspberry Pi Zero W running ARMv6? That would explain the segmentation fault running the assembler.

 cd /tmp/pip-install-L5wV40/psutil/
-bash: cd: /tmp/pip-install-L5wV40/psutil/: No such file or directory

running this on a Raspberry Pi Zero

Not quite :slight_smile:
Revision : a02082 = Pi 3 Model B
Linux octopi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux

From here, you might try...

sudo service octoprint stop
source ~/oprint/bin/activate
pip install psutil

Obviously, it needs an Internet connection throughout for this to work.

>pip install psutil
Requirement already satisfied: psutil in ./oprint/lib/python2.7/site-packages (5.6.2)

I have a hard time believing that. I think I would:

source ~/oprint/bin/activate
pip install --upgrade --force-reinstall psutil
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020.
>pip install --upgrade --force-reinstall psutil
(oprint) pi@octopi:~ $ pip install --upgrade --force-reinstall psutil
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at
Looking in indexes:,
Collecting psutil
  Downloading (449kB)
     |████████████████████████████████| 450kB 594kB/s
Building wheels for collected packages: psutil
  Building wheel for psutil ( ... error
  ERROR: Command errored out with exit status 1:
   command: /home/pi/oprint/bin/python2 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-pzoKzz/psutil/'"'"'; __file__='"'"'/tmp/pip-install-pzoKzz/psutil/'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d /tmp/pip-wheel-6s4TD0 --python-tag cp27
       cwd: /tmp/pip-install-pzoKzz/psutil/
  Complete output (48 lines):
  cc: internal compiler error: Segmentation fault (program as)
arm-linux-gnueabihf-gcc: internal compiler error: Segmentation fault (program as)

WARNING: You are using pip version 19.2.3, however version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

I did that and now I have octoprint without anything:

So I did:

pip install --upgrade --force-reinstall
arm-linux-gnueabihf-gcc: internal compiler error: Segmentation fault (program as)

Is my rasbian damaged? I try to reinstall all Rasbian packages, 648 to go...

That is a good question. And I don't know the answer to that. You might try:

sudo apt-get update
sudo apt-get upgrade

...followed by that earlier attempt to force-install psutil.

Or... you could take a page out of my book, buy another microSD and flash a fresh install of OctoPi onto there.

1 Like
apt-get upgrade

All up-date.
I cleared SD card and installed everything from scratch (Rasbian and Octoprint install manually).
It's working, v. 1.4.0, but, as usual, I have still small problems, I noticed:
plugin PrintTimeGenius doesn't show Layer xx/yy it's "Layer -", time and % is ok

but the most irritating - octoprint service and mjpg_streamer and haproxy don't start with system. I tried

  • editing rc.local
  • /etc/init.d and update-rc.d xx defaults
  • systemctl enable xxx

service octoprint start do nothing, I have to start it ./octoprint serve
but I think it's a "feature" a new Rasbian system.

Did you use the OctoPi IMG or some other method of installing this to your microSD?

I installed Rasbian Buster Lite and then Octoprint according to this Setting up OctoPrint on a Raspberry Pi running Raspbian

Sounds like you're making things harder on yourself. Guy & Foosel put a lot of time into creating a process which creates an IMG file. Flash that to your Pi, edit the wifi configuration and you've hit the ground running.

You won't have to fuss with rc.local, modifying users, init.d, systemd, expand the filesystem, setup a Pi camera, etc, etc.

You will have to install PrintTimeGenius, though.

This is not that I'm the best IT guy around here but sometimes I prefer do something by myself, especially that on Octoprint page there are two ways to install it - ready system and simple installing. However you say installing is bad and I should get the whole system. That is exactly what I did last time and what caused the problem I described.
Never mind that - there is no point in further discussing that. The problem is solved but by getting a new system, what is not always so easy.

Honestly, I'm the kind of guy who will also "roll my own" solution if I can. It's how I learn.

1 Like

Had the same issue when trying to upgrade - the solution was reinstalling the binutils package, which contains the as binary, i.e.
sudo apt-get install --reinstall binutils


WOW! So simple...