Latest OctoPrint break Dashbard plugin?

I updated to the latest OctoPrint and now my Dashbard plugin does not work. I tried uninstalling it and re-installing it to no avail. At the bottom is says Is DisplayLayerProgress installed and it is installed.

The Dashboard plugin also seems to break OctoLapse page. When Dashboard plugin is installed, It just keeps trying to load OctoLapse page, but when I uninstall it, it works fine.

I've updated everything to latest from the Software Update tab.

The big question: You updated OctoPrint, but you didn't mention what you updated from...

There were some issues with DisplayLayerProgress recently but if I had to guess this is an issue with that particular combination rather than whatever OctoPrint update.

I updated it from Software Update tab in settings.

I fixed it. Had to update the Pi itself via SSH and doing a

sudo apt update
sudo apt full-upgrade

Yeah I get that... What version were you on before the update. If you upgraded from 1.2.0 to 1.5.3 then yeah a lot of stuff would break. If you go 1.5.2 to 1.5.3 then no. It's not about where you updated it, or that you updated at all but the difference.

Can you upload your octoprint.log file and check what messages appear in the browser console?

1 Like