Layer indicator not found in file [DisplayLayerProgress]


at first sorry for my bad english... its not my native language.

I've issues with the DisplayLayerProgress Plugin: It doesen't matter how i upload the file, it doesn't matter what ever i change in the code. The error "Layer indicator not found in file" still occurs ;(

I m not sure if i miss something, but i tried different settings inside the regex and nothing works.
I'm using Simplify3d. Part of my gcode inside an uploaded file is like:

; process Process1
; layer 1, Z = 0.120
; tool H0.120 W0.510
; skirt
G1 X143.823 Y67.056 E6.6506
G1 X143.587 Y66.820 E6.6585
; layer 2, Z = 0.220
M106 S153
; tool H0.100 W0.300
; inner perimeter
G1 X115.471 Y72.172 F12000
G1 Z0.220 F1002

So i have the layer information inside the gcode ?
The only information that i get inside the layer informations:
Progress: 11% Layer: - of - Height: 2.3 of -mm

Anyone have an idea what it could be ?

Thanks in Advance

The DisplayLayerProgress plugin is configured to recognize the layer data from multiple slicers including S3D unless you have changed the default via post processing.

If it isn't working for you, it probably can be "tweaked" to recognize your gcode. Open OctoPrint Settings, DisplayLayerProgress and verify that its configuration matches your slicer. If you think it does and it still doesn't work, then you may need to open an issue on the plugin's website.

Note: DisplayLayerProgress doesn't work on files uploaded to OctoPrint before you installed the plugin. You need to download, delete, and upload the file again.