LED initialization failed

it's my first time using octprint with plugin WS281x LED Status. All tests run fine. But my stripe will not turn on. In the debug log I get this error:

[2021-05-01 10:18:56,598] INFO: Initialising LED strip
[2021-05-01 10:18:56,603] ERROR: RuntimeError('ws2811_init failed with code -5 (mmap() failed)')
[2021-05-01 10:18:56,603] ERROR: Strip failed to initialize, no effects will be run.

I tried different GPIOs. With all the same issue. I measured the power on the stripe. It's 4.9volts.

Any idea? Any help? I'm a greenhorn, sorry.

Is that with GPIO 10 selected?

What OS see you using? What Raspberry Pi?

Hi Charlie,

this is an excerpt of my systeminfo:

connectivity.connection_check :
connectivity.connection_ok : true
connectivity.enabled : false
connectivity.online : true
connectivity.resolution_check : octoprint.org
connectivity.resolution_ok : true
env.hardware.cores : 4
env.hardware.freq : 1500
env.hardware.ram : 3959304192
env.os.bits : 32
env.os.id : linux
env.os.platform : linux
env.plugins.pi_support.model : Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version : 0.18.0
env.plugins.pi_support.throttle_state : 0x0
env.python.pip : 20.3.3
env.python.version : 3.7.3
env.python.virtualenv : true
octoprint.safe_mode : false
octoprint.version : 1.6.0
systeminfo.generator : systemapi

I tried it with GPOI 10, GPIO18 and GPIO21. And I set this GPIO config in your plugin :slight_smile:

There should be no issue, that setup is standard. The specific error you are seeing is I believe related to accessing the memory, I don't have a fix right now but will keep thinking.