Loosing connection and no temp readings with latest Marlin Firmware (bug fix 2.0.x 29-01-2021)

What is the problem?

I have recently complied a new firmware for my Ender Pro 5 using the Marlin bug fix 2.0.x 29-01-2021 Firmware. Now after a few minutes of connection I get the error Offline (Error: Too many consecutive timeouts, printer still connected and alive?)

I used to use Octoprint with the same printer but using the Creality Firmware and Octoprint had no connection errors.

What did you already try to solve it?

Different cables and they have he 5v tape applied as well.

Have you tried running in safe mode?

Yes the same error happens

Did running in safe mode solve the problem?

No

Complete Logs

2021-02-02 01:47:39,505 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log
2021-02-02 01:50:35,513 - Enabling serial logging
2021-02-02 01:50:39,177 - Changing monitoring state from "Offline" to "Opening serial connection"
2021-02-02 01:50:39,196 - Connecting to port /dev/ttyUSB0, baudrate 115200
2021-02-02 01:50:39,250 - Changing monitoring state from "Opening serial connection" to "Connecting"
2021-02-02 01:50:39,277 - Connected to: Serial<id=0x71f74830, open=True>(port='/dev/ttyUSB0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=30.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
2021-02-02 01:50:39,286 - Send: N0 M110 N0125
2021-02-02 01:50:41,584 - Recv: ok
2021-02-02 01:50:41,597 - Send: N0 M110 N0
125
2021-02-02 01:50:41,613 - Changing monitoring state from "Connecting" to "Operational"
2021-02-02 01:50:44,866 - Recv: ok
2021-02-02 01:50:44,884 - Send: N0 M110 N0125
2021-02-02 01:50:49,628 - Recv: ok
2021-02-02 01:50:49,634 - Send: N1 M115
39
2021-02-02 01:50:53,032 - Recv: FIRMWARE_NAME:Marlin bugfix-2.0.x (Feb 1 2021 22:38:13) SOURCE_CODE_URL:github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:Ender-5 Pro 4.2.2 EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
2021-02-02 01:50:53,085 - Recv: Cap:SERIAL_XON_XOFF:0
2021-02-02 01:50:53,089 - Recv: Cap:BINARY_FILE_TRANSFER:0
2021-02-02 01:50:53,097 - Recv: Cap:EEPROM:1
2021-02-02 01:50:53,101 - Recv: Cap:VOLUMETRIC:1
2021-02-02 01:50:53,109 - Recv: Cap:AUTOREPORT_TEMP:1
2021-02-02 01:50:53,119 - Recv: Cap:PROGRESS:0
2021-02-02 01:50:53,125 - Recv: Cap:PRINT_JOB:1
2021-02-02 01:50:53,133 - Recv: Cap:AUTOLEVEL:1
2021-02-02 01:50:53,141 - Recv: Cap:RUNOUT:0
2021-02-02 01:50:53,161 - Recv: Cap:Z_PROBE:1
2021-02-02 01:50:53,164 - Recv: Cap:LEVELING_DATA:1
2021-02-02 01:50:53,166 - Recv: Cap:BUILD_PERCENT:0
2021-02-02 01:50:53,187 - Recv: Cap:SOFTWARE_POWER:0
2021-02-02 01:50:53,190 - Recv: Cap:TOGGLE_LIGHTS:0
2021-02-02 01:50:53,193 - Recv: Cap:CASE_LIGHT_BRIGHTNESS:0
2021-02-02 01:50:53,195 - Recv: Cap:EMERGENCY_PARSER:0
2021-02-02 01:50:53,198 - Recv: Cap:PROMPT_SUPPORT:0
2021-02-02 01:50:53,217 - Recv: Cap:SDCARD:1
2021-02-02 01:50:53,220 - Recv: Cap:REPEAT:0
2021-02-02 01:50:53,223 - Recv: Cap:AUTOREPORT_SD_STATUS:0
2021-02-02 01:50:53,245 - Recv: Cap:LONG_FILENAME:0
2021-02-02 01:50:53,251 - Recv: Cap:THERMAL_PROTECTION:1
2021-02-02 01:50:53,253 - Recv: Cap:MOTION_MODES:0
2021-02-02 01:50:53,256 - Recv: Cap:ARCS:1
2021-02-02 01:50:53,257 - Recv: Cap:BABYSTEPPING:1
2021-02-02 01:50:53,259 - Recv: Cap:CHAMBER_TEMPERATURE:0
2021-02-02 01:50:53,261 - Recv: Cap:MEATPACK:0
2021-02-02 01:50:53,264 - Recv: ok
2021-02-02 01:50:53,266 - Send: M21
2021-02-02 01:50:55,987 - Recv: echo:SD card ok
2021-02-02 01:50:55,993 - Recv: ok
2021-02-02 01:50:56,007 - Send: M105
2021-02-02 01:51:00,261 - Recv: ok T:200.00 /200.00 B:60.01 /60.00 @:81 B@:0
2021-02-02 01:51:00,276 - Send: M155 S2
2021-02-02 01:51:04,448 - Recv: ok
2021-02-02 01:51:04,462 - Send: M20
2021-02-02 01:51:07,454 - Recv: Begin file list
2021-02-02 01:51:07,512 - Recv: FIRSTL~1.GCO 25675
2021-02-02 01:51:07,516 - Recv: CE5_PO~1.GCO 55824
2021-02-02 01:51:07,519 - Recv: /TECBEA~1/3DBENC~1.GCO 4349350
2021-02-02 01:51:07,521 - Recv: /TECBEA~1/CE5_TE~1.GCO 1202878
2021-02-02 01:51:07,526 - Recv: /TECBEA~1/CURAAC~1.GCO 262170
2021-02-02 01:51:07,528 - Recv: /TECBEA~1/3DRETR~1.GCO 233404
2021-02-02 01:51:07,531 - Recv: /TECBEA~1/FIRSTL~1.GCO 25675
2021-02-02 01:51:07,533 - Recv: /TECBEA~1/CE5_PO~1.GCO 60372
2021-02-02 01:51:07,535 - Recv: CE5_EN~1.GCO 659377
2021-02-02 01:51:07,537 - Recv: End file list
2021-02-02 01:51:07,541 - Recv: ok
2021-02-02 01:51:07,543 - Send: M105
2021-02-02 01:51:10,953 - Recv: ok T:199.86 /200.00 B:60.37 /60.00 @:85 B@:0
2021-02-02 01:52:41,025 - No response from printer after 3 consecutive communication timeouts, considering it dead. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
2021-02-02 01:52:41,040 - Changing monitoring state from "Operational" to "Offline (Error: Too many consecutive timeouts, printer still connected and alive?)"
2021-02-02 01:52:41,056 - Connection closed, closing down monitor

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version 1.5.3, Octopi Version 0.17.0, running on Raspberry Pi 3 Model B Plus Rev 1.3

Which mainboard are you using?

I vaguely remember someone in Discord saying something about this and think the resolution was updating the bugfix branch to the latest version as there was something broke in that specific release cycle that had an issue. But being yours seems to be very recent, not sure if that would be the same for you. Have you attempted with a stable release versus the cutting edge bugfix branch?

2 Likes

I am using the v4.2.2 board with the silent steeper motors.

Please read:

In short, Marlin bugfix has had a lot of serial issues over the last few days, this is not OctoPrint's problem but instead Marlin's, they are working hard to fix it and from what I can see the issues are mostly solved. You have some options:

  • Don't use Marlin bugfix and instead use the stable release
  • If you must use Marlin bugfix, understand that it is not for production use and while it is usually stable, it sometimes is not and if you encounter issues report them to the Marlin firmware community so that they can be fixed.
  • Just live with the issues and risks that running a development build entails.

I recommend updating your firmware, since it is now outdated.

4 Likes

Brilliant thank you. I will look at using an earlier version. This was must first attempt and building a new firmware for the printer.

2 Likes

Just to let you know I've recompiled using version 2.0.7.2 and the Octoprint connection is stable again and temperatures are all being read and shown

3 Likes

I have had many issues with Marlin Firmware on ANY of my control boards. The biggest issues are related to bad performance of firmware. Usually they show up as printer movement is intermittently interrupted, or communications to the host being interrupted (and then usually resumes). After messing around with many versions of Marlin Firmware I could not get any of them to work properly and perfectly.

I like to support Marlin since they are Open Source, but the firmware is just too buggy and community is usually unable to help with these types of technical issues. Unfortunately at this point I have had to given up on the entire project. I'm sure that some integrators and retailers are able to successfully integrate Marlin in their device and ship working systems to customers, but basically if you are upgrading the firmware yourself and trying to configure it, you will most likely run into firmware issues. I would suggest you to go back to Marlin community and report to them and hope that someone can clean up the code and fix the bugs at some point. Otherwise you got to go through the spaghetti code yourself and figure out what module is making the microcontroller laggy and fix it yourself.

Currently all my printers are running the Repetier Firmware and I have had exactly zero (0) issues with any of the printers. It is not ideal (since it is not Open-Source), but the printers work perfectly and I have not had to do any fiddling around for a long time. This is how firmware should work, just configure it and dial all the right settings in, and once it is in the machine, you basically forget it since it just works and operates the hardware properly.

For what its worth, this was broken between 28th Jan and 1st Feb 2021. There are no known issues outside of this date range.

@CRCinAU - good to see you around here. Assuming you operate the site https://marlin.crc.id.au?

We do have a request/strong suggestion, this has been discussed at length recently, due to the issues mentioned on this post and elsewhere

Our request is to either provide the equivalent of a 'stable build' on that site, currently Marlin 2.0.7.2, or specifically point out that these are development nightly builds, and may not always be stable. It's a great site, and we fully support the idea but when it all goes wrong (as it did a couple days ago) it causes a significant amount of overhead when so many people are running bugfix branches of Marlin, which are frequently changed.

On part of the problem is this:

  • The site targets those who do not want to build their own firmware, so they are less inclined to know what problems are, how to report them and how to change to a different build.
  • The bugfix branch is usually quite stable, and doesn't have many issues. This seems to have created a false sense of security with what is essentially a development branch.

It has taken quite a lot of effort over the last few days to field these problems, especially when people seem to forget how to read in some replies. I appreciate these prebuilt firmware probably eliminate a lot of the 'build is not working' issues people have with Marlin, so this is a kind of 'compromise' we have thought of.

2 Likes

Its a catch 22. The most popular features just aren't available in stable builds.

As an example, MeatPack - which is a new binary wire level protocol that has an OctoPrint plugin - fixes the issue of low bandwidth to the printer which in turn fixes a ton of print issues won't be in any stable build for months. But its available now in bugfix - and it effectively doubles the throughput of the serial port.

What I normally try to do (which I didn't get to do this time - my bad) is put something in the Known Issues section of the download pages when something becomes known.

That was one of the points that came up - it was a perfect storm, no tagged release for a while, new Meatpack plugin was announced to all users and then the serial issues - but there were still cases of people not realising that these builds were not necessarily going to be stable at all times.

Yep - 100% agreed - which is why the site keeps at least 7 days of prior builds (currently expanding to 14) - as we don't seem to have breakage lasting for that long.

I guess the key part for me is that I need to do an improvement to the site that allows me to set an announcement similar to the announcement in the forum software here that can persist on all pages.

Currently, its a manual editing of the firmware details on each page - and I just didn't get time to do that this time around. Having this in a single place would allow me to be much more efficient in this area.

I would actually say that the majority of cases we have seen the past few days were from people who didn't care about meatpack or new features in general and just needed a build that isn't whatever came stock with their printer (because stock Creality firmware tends to have severe issues).

Please do not underestimate the amount of your users who are completely new in the game and just need a verified stable build to learn on. Nightly builds are not what you want to drop on a newbie, problems like these will happen again.

So please do not only consider an announcement feature (from our experience here, it will not have the desired effect - people don't read) but rather a prominent "stable" category as well. Seven days of builds don't help a user who has absolutely no idea of what they need to click on (and we literally had this discussion on here with a completely frustrated newbie who just wanted to print and didn't care about current development features at least twice just in the past few days).

ETA As also just mentioned in my initial requests in your feature request section:

I agree that the current quite support intense situation came from a perfect storm that coincided with the meatpack release, but the meatpack release wasn't the cause. The cause was a refactoring of the serial communication inside Marlin that broke some stuff temporarily - totally valid for a development branch, not uncommon to happen during development and all the more reason to offer stable builds as well to people are completely out of the depth when it comes to building firmware and/or don't want to flash anew every other day but rather just want something that is tested and works. Most of these people currently don't even know they are running potentially unstable development builds.

4 Likes

@CRCinAU - in a perfect world, being able to point new users to a stable, reliable build would be great. Right now I can't point people to any one source, certainly not to Creality to get it.

Having a freely available "Ender 3 Stable OctoPrint Ready" base* firmware that would allow people to print SD, display and connect OctoPrint would be appreciated. Yeah, I know it doesn't help sales in the front.

  • And yes, I understand how Creality has made a mess of things with v1.1.x/4.2.2/4.2.7, 8 vs 32-bit, silent vs not silent boards. Makes me want to force feed Surströmming to the people at Creality that do this.
2 Likes

Hi. A very interisting topic.
Let's give my input on this, especially for the Marlin-users, not only on Creality printers.
I've been using and testing it now for a couple of days on an Anet ET4 as was listed on Anet's site.
And: yes it is "standard" going to the bugfix-version and it works fine when printing from micro-SD, but also connection-problems when trying to print from USB.
Because I have read about this topic here, it is fine.

But: there is something in the name 'bugfix'. Maybe for newbies and non-English people? It seems to be the version that fixes the bugs in 2.0 instead of beeing a 'try it out and report' version.
Why not mention it on the startscreen of the printer. A short warning that 'this is a test-version, please report bugs' would be sufficient to warn a lot of users.

I still love both Octoprint (6 running, most not connected on internet but only internal network) and Marlin!

Its kinnda ironic that the bugfix version of Marlin is the most likely to have bugs.

1 Like

I strongly suggest you request this on the Marlin bugtracker. The only thing we can do from OctoPrint's side, show such a warning in OctoPrint, has already been implemented in the bundled FirmwareCheck plugin for preceisely this reason.

Hi Gina.
Yes I did request it there.
On reading on issues posted here in the logfiles I also keep on reading that the firmware-check has been disabled.
Is it possible to give an extra warning in Octoprint, for example when someone is changing the printersettings while firmware-check is disabled?
I really get the feeling that at the moment this is really the biggest problem since Octoprint is pretty stable and working well!
On some other forums on facebook I have read also that Octoprint was giving problems and these are mostly starting after the firmware-update with Marlin. Users just download some file, put it on sd-card and start the printer thinking that 'all is well now' but instead creating problems for themselves and then blaming octoprint :frowning:

I can't stop people from disabling the firmwarecheck, that's their right that I won't take away from them. OctoPrint warns you if you disable it, tells you why it's a bad idea. If you still do it, well, ok. I have already spent way too much time on trying to keep people from shooting themselves in the foot with broken printers and firmware, and having the plugin warn them of the risks if they decide to disable it, I have to draw the line somewhere and that is at constantly nagging them when they disable against all prior warning. There will always be people who find a new exciting way to shoot themselves in the foot after I've closed off one way to do so.

I can only lead people to water, I can't make them drink.

4 Likes