Ls: cannot access '/dev/serial/by-id/': No such file or directory

I have problem with access to my printer after installing klipper. I have SKR MINI e3 1.2 as controller. All configuration is ok.
When i want to check path to controller that appears:

ls: cannot access '/dev/serial/by-id/': No such file or directory.

Up to this time i changed USB cable, changed plugins, checked configuration in Putty to see if I checked USB. Do you know where I could do mistake?

When the printer is powered on and you plug the usb cable in and then ssh into the pi and type:
sudo dmesg
does it report a new full-speed USB device, Product: Maple, Manufacturer: LeafLabs ?
Or any errors that would shine some light on the problem?

that commend only tell me that there are new high-speed
Moreover only that things are error(red color):
[ 7.663929] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6

[ 7.958575] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[ 7.968594] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar 23 2020 02:19:54 version 7.45.206 (r725000 CY) FWID 01-88ee44ea

If you want i can send all message which i got from that commend.

The part you posted doesnt look like the pi can see any usb device. The printer was powered on when you tried it? Same non-result with different usb-cables? The cable is a data-cable, not the cheap things that only transmit power to a phone or something?
And you did enable things in Marlin and flashed the printer with the new firmware? (Alternatively, flash it with BTT's -USB firmware)?




(taken from OctoPrint-FirmwareUpdater/ at e00884d23bc6446d30db000b23baafcd4af3c652 · OctoPrint/OctoPrint-FirmwareUpdater · GitHub)

Yes, printer was powerd on, i tried with 3 cables and to all 4 different plugins in RPi. I didn't use Marlin, only Klipper. And after that configuration(installing Klipper, configure to SKR MINI e3 1.2, put firmware to sd in SKR and put printer.cfg to sd in RPi) that error appear. It looks like you wrote that RPi can't see that USB, but in Klipper Firmware Configuration i checked to use USB.

dmesg shows the kernel messages. When something get's connected to usb ports and can be recognized as an usb device then the kernel will say so.
I have the same board you have, but Marlin 2.0x on it and when the printer gets powered on a message block gets written starting like

usb 1-1.3: new full-speed USB device number 35 using dwc_otg
usb 1-1.3: New USB device found, idVendor=1eaf, idProduct=0029, bcdDevice= 2.00
usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.3: Product: Maple
usb 1-1.3: Manufacturer: LeafLabs
usb-storage 1-1.3:1.0: USB Mass Storage device detected

(there is more to that, these lines are just the usb part.)
If this does not appear in your output then the problem is on the other side of the usb port.
Can't help you with Klipper as I have next to no experience with it.

You may check with a PC if a USB connection can be established.

I hope the printers USB is not broken.

The USB cable is ok, cause i checked it on card reader. I have almost the same if it comes about USB:

usb 1-1: New USB device found, idVendor=0424, idProduct=2514, bcdDevice= b.b3
usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected
usb 1-1.1: new high-speed USB device number 3 using dwc_otg
usb 1-1.1: New USB device found, idVendor=0424, idProduct=2514, bcdDevice= b.b3
usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
hub 1-1.1:1.0: USB hub found
hub 1-1.1:1.0: 3 ports detected

I understand that. Sorry that I ask, but Marlin is easier than Klipper to configure?

Have you tried to connect your printer to a PC using pronterface yet? It is to check if the printer is connective at all.

They are different. Changes and optimisations are faster made with Klipper.
In Klipper you just put in the things you really need. In Marlin you have to search for some things. (BTW: Klipper does not support SD cards on the printer for printing)

Well, that is probably not your printer but the usb hub of your pi.

I'll pass that on to @inmate5 :sunglasses:

Thank you guys :smiley: