[M3D] lmiting bed size and cura first travel to front-left


#1

Hey,
So when Cura on M33-Fio starts it goes all the way to the front left of the printer.
However, in order for my M3D to work I had to add a fan to cool the gears, I used this part:

Now the fan hits the front left of the build frame. So I want to limit the extruder travelling there.

I tried setting the bed size to 70mm on x and y as a test, re-slice, and try again, but it still goes to that position.

Any way to enforce this limitation?


#2

When you say "Cura" do you mean the one that's embedded in OctoPrint or the stand-alone version?

I know that OctoPrint's Settings -> Printer Profile for your printer includes various settings but it's possible that these are only used in the buttons as seen in the Control tab.

If you slice in the stand-alone version of Cura, then see if adjusting the printer's X/Y perhaps. Not sure exactly how it's bumping on your printer.

It might instead be necessary to go into your printer and to move the left end-stop switch rather than fussing with everything in the firmware/software areas. Many times when you choose to HOME the X/Y motors, it just moves left and back until either end-switch is in the TRIGGERED state as seen via the M119 report. Then the printer knows that this is the zero point. This may slightly reduce your print volume. So then you probably should reduce the maximum X/Y to compensate for the reduction you made on the other side of the printer... or not. (Try it and see if it still works.)

Me, I tweaked the end-stops further out and then adjusted the maximums slightly more to add about 75 cubic mm to my print volume. It's the reverse of what you're doing.


#3

Will note that the M3D uses a specialized plugin, this is why this is in the plugin section.

When you say "Cura" do you mean the one that's embedded in OctoPrint or the stand-alone version?

I am using the standalone. The M3D, M33 FIO plugin comes with a full blown slicer and I am using that.

I know that OctoPrint's Settings -> Printer Profile for your printer includes various settings but it's possible that these are only used in the buttons as seen in the Control tab.

They seem to be set in th Cura settings parameters aswell in the "advanced" tab.

If you slice in the stand-alone version of Cura, then see if adjusting the printer's X/Y perhaps. Not sure exactly how it's bumping on your printer.

No idea. That is why I am asking

It might instead be necessary to go into your printer and to move the left end-stop switch rather than fussing with everything in the firmware/software areas. Many times when you choose to HOME the X/Y motors, it just moves left and back until either end-switch is in the TRIGGERED state as seen via the M119 report. Then the printer knows that this is the zero point. This may slightly reduce your print volume. So then you probably should reduce the maximum X/Y to compensate for the reduction you made on the other side of the printer... or not. (Try it and see if it still works.)

The M3D has no endstops. Its a strange printer.

Me, I tweaked the end-stops further out and then adjusted the maximums slightly more to add about 75 cubic mm to my print volume. It's the reverse of what you're doing.

I can't do that


#4

So it looks like it has a pair of accelerometers in a chip, if I'm guessing correctly. I don't really see how that's a replacement for end-stop switches, though. I guess it's just to know if you tried to move... and it didn't...?

From the manual, it's possible that running the bed calibration could detect the lack of movement and adjust the home defaults.

Another option is to redesign the shroud so that it no longer bumps.

:laughing: Or you cut trim some of your X-rack off as suggested in their support area.


#5

I am using the iMe community firmware. So there might be more freedom to set things up there.

I am not sure I want to cut the teeth and limit the movement forever. I might find a better way to cool in the future.