Marlin Unresponsive "Wait, wait, wait..."

What is the problem?

I have a new mainboard, BTT Turbo E3 running recent stable build of marlin. Screwing with assigning functions to keyboard today, most notably some "quik print" M23/24 commands.

I start printer and pi. It lists is specs and starts saying "Wait". I get some response through USB keyboard, I fire off a test print (must use lower case for some odd reason in command, but files need upper cased), I then cancel it (via lcd, M524 has no effect), and start another, cancel that. Then it becomes totally deaf. Wait, wait. It only takes M410 and M112.

What did you already try to solve it?

Reset many times

Have you tried running in safe mode?

Won't affect my problem

You don't need whole bundle. Here is todays serial.log.
serial (2).log (48.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.7rc (notablly using the USB keyboard plug today), pi?, ender3pro with BTT Turbo E3 (newly installed!!), marlin 2.0.9, Chrome (recent build), Windows 10 pro, virgo, single, male, white, 39, unemployed, facing felony and misdemeanor charges of child endandergment. Living in westerville ohio with dad, favorite color is blue, very depressed, wife left me. Last BM was quite loose and greenish. ok thats all the info i got.

I'm sorry this is mostly a Marlin issue but I like this forum.

I took a walk after restarting it again. Fired off a print from LCD controller and it started fine it seems and i stop it from lcd controller before bed warms up. I then cool it down from USB keyboard and try a subsequent command a second later via usb keyboard. Nothing. I then hit the "Stop!" key, that worked. Again, same issue. Attaching.
serial (3).log (107.0 KB)

PPS: It doesn't hang up when I started and stopped print from OP. So not op issue but you guys are smarter than I

1 Like

Problem went away slowly on it's own. Maybe it had something to do with the M524 bug! I took it out and now it responds fine.

1 Like

Great you found it. So could you please:

1 Like

Didn't notice that little checkbox nor wouldn've known it was "solved". I did look.

1 Like