Move the lines please


#1

Can you move the temp lines. If you don't use the bed it hides the temp of the extruder


#2

Why not instead just set your printer profile correctly?

OctoPrint -> Settings -> Printer Profiles -> your printer -> edit -> Print head & build volume -> Heated bed = unchecked


#3

That removes it. I want to MOVE it so it's out the way of the extruder temp


#4

I have to admit that I've never seen this problem myself because my bed is never at 36°C at ambient temperature O_O

The problem is - where to move it? If I move the legend up the upper left then the same issue will arise if the hotend is at temperature. Which is actually why it's where it's at - least risk of interference at normal operation. Putting a more or less opaque background color on the legend also doesn't really help here (I just tried).

Even some funky logic like "temperatures below 100 -> up, above 100 -> down" won't work because if you have the bed off and the extruder on, what should it decide on?

As you can see, simple request, ultra complex problem. For which I think the current position is probably the best one.


#5

Yer, the bed temp doesn't move until 50* so any temp below that would still cover it. maybe move the graph up, Start at 20 .

It wasn't 32 in the house that was after a print but just happened to be the screen shot :slight_smile:


#6

There are people with printers in cold garages which have ambient below 20. Those would probably get angry if their graphs didn't show properly anymore. There are also people with more than one extruder + bed + (in 1.3.11) chamber temperature on there, so that thing can climb up a bit.

The only other option would be to move the legend outside of the graph altogether and that brings a whole rat's tail of adjustments with it which I'm frankly not seeing justified for the rare case of "a line on the graph makes the legend a bit harded to read" :confused:


#7

LOL I can understand that.


#8

I used to see it all the time, I kept the print room at around 35 degrees with a heater, my solution was to just install the navbar temperature plugin and never look at the temp graph legend :slight_smile:


#9

The only time mine are at the same place is when I'm not printing anything, at which point it doesn't really matter. Once I turn it on, the lines move

PS. Mine is in a cold basement, sometimes the temp is as low as 10C on a really cold day. That's when those lines come in really handy.

I move the nozzle up about 10CM above the bed, and turn on the bed heater to about 60-70C. When I see the nozzle temp reach about 25C, I know that the inside of the enclosure has warmed up sufficiently to start the print.

I do have a thought tho. Is there any way to add a 3rd line to the graph ? Like if I was to install an enclosure thermistor ?

Or is there already a plugin for that ? There are so many I can't keep track anymore


#10

See this comment - chamber temperature will be included starting with 1.3.11, if configured in the printer profile and supported by the firmware.