MQQT Plugin - Friendly name

I'm finally getting around to setting up my system a bit better and wanted to add my Prusa to my home assistant. It is using Octoprint on a Pi Zero direct on board.

Everything setup well however the broker told me this.

1590240329: New client connected from as 57qzPD8w7mq7wulIjeDYlX (p1, c1, k60, u'mqqt').

I had assumed that it would use the Hostname as a friendly name or something. I went all through the settings and could not find where I could give a friendly name, nor could I work out where this GUIDy thing is coming from. Is it possible to have a more meaningful name or am I stuck with this. Should I need to change the Pi or something (hoping for a more powerful Zero one day ;-)) will I then have to change everything else?

ta for any help.

@tre4bax maybe the The broker requires static client id, show options option is what you're looking for? You may have to restart OctoPrint once this setting is changed, I'm just not sure if that is one of the monitored settings that will re-establish the connection or not.

That's it, many thanks Jneilliii. Totally missed that when going through. Would be better if that was always shown but with an optional fill in.

Up and running now though so that is excellent.

Glad to help.