My new "bq hephestos 2" setup


#1

Hi,

this is my setup, located in Munich Bavaria :wink:

bq hephestos2 with heated bed

original Marlin firmware 1.1.8. and adjusted to my setting
(the original firmware from bq made to many problems)

octoprint on raspi.

Since I have this setup, the printer runs reliable, stable, wonderful :wink:


#2

I had the same problem than you (ive read somewhere in google groups), that the printer loses connection after M800 on print start when extruder is in the middle of the bed. Any solution to that?

Is there any disadvantage when using original marlin than using bq's? and how to "flash" that firmware?

Would be great to share your settings with us. :slight_smile:

thx for your reply


#3

Hi,

you are right I had exactly the same problem.

Here is a brief overview how to flash the hephestos 2 with the original Marlin FW.

I downloaded the software from http://marlinfw.org.
This is the source code. The config files for some printers are in the sub-folder "examples".
Just copy the 3 files in the Marlin root directory.

I made these changes in the configuration.h file.

#define HEPHESTOS2_HEATED_BED_KIT
//define MIN_SOFTWARE_ENDSTOPS
#define Z_PROBE_OFFSET_RANGE_MIN -4

You must install the Arduino IDE from https://www.arduino.cc on your PC.
Inside the App you must download the U8glib and update the libraries

Set the board to Mega2560 and the port to usb.

Connect your printer to the PC and click "upload". The Arduino IDE will compile and upload the firmware to the printer

How to setup the Z-Offset with the new firmware is explained in this little video.


#4

Thank you so much for your infos. I will try it :blush: :slight_smile:


#5

I just love that Raspberry Pi mount there! :smiley:


#6

OK, i flashed marlin and its working. I set z offset correctly, so that the nozzle is nearly on bed when being at z0.
but when i start to print, it prints by far too high (~5mm)

any idea what i did wrong?

How should i slice? on octoprint (with which profile)? or maybe with cura on desktop, but will hephestos2 profile of bq work proper with vanilla marlin?

sometimes display says: G28 Z forbidden

thx for your answer :slight_smile:


#7

The setup for the Z-Offset is different to the bq firmware.
Its a manual way.
You must follow the instruction from the video.

  1. check the current Z-offset under control->motion->Z
  2. goto prepare->Move Axis and move the Z-axis in 0.1 steps to the print bed
  3. stop when the extruder touches the print bed
  4. add this Z-value to the value under Control->Motion-Z
  5. Save the settings

You can slice like before, with the same settings, in Cura and upload the sliced files to octoprint.
or
you can slice in octoprint.

  1. install curaEngie
  2. import the the different profiles from bq for Cura..

now you are able to upload STL Files to octoprint and slice there..

If you upload the stl-files to octoprint a new dialog for the curaEngine


#8

You will find the 3D-Files for the Raspberry Pi Mount on my Thingiverse Profile.

Have Fun

Patrick