New Camera Stack C922 no preview

Camera model

Logitech C922 Pro HD

What is the problem?

Octolapse preview of timelapse during print and after render not working
No snapshot preview during timelapse & Preview of rendered video does not showing any picture or video.

What did you already try to solve it?

Disabled Timelapse and set up Camera Streamer
accessed webcam at octopi.local/webcam/webrtc - all showing correctly
used test buttons to verify ffmpeg path
Dissabled classic webcam plugin

Octolapse is taking snapshots and rendered timelapse play fine once downloaded to my local PC.

Timelapse preview window opens in Octoprint but the play button does nothing and the preview screen stays blank.

Also during the print no snapshots show up in the Octolapse preview window

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (570.8 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.93
Octopi 1.0
Prusa Mk3S+
Bing / Chrome
Windows 11

I have found this discussed here -

Timelapse previews not generated with Pillow 10.0.0 · Issue #917 · FormerLurker/Octolapse (

The fix is fairly straight forward so marking this as solved.