New firmware for WYZE convert to WEBCAM

Wyze just announced a new firmware to convert the Wyze Camera to a Webcam, won't be able to connect to the application, just via the USB:

I just saw this too. Does anyone know if the picture quality of Wyze would be better than a c920?

I'm curious if a pi would even see it as a camera...

4. This may or may not be compatible with your computer operating system. We have tested and confirmed that it works on Mac OS 10.13, Windows 7 and 10.

OK. So I tested this out. And it works. I'm using Linux Mint(Ubuntu), but I see no reason why this wouldn't work on a Pi as well. I did a writeup on it. This might actually be useful for anyone looking for a webcam for OctoPrint or anything else since webcams are pretty much out of stock every where or being price gouged because everyone is working from home.

And my blog post talks about splicing together 2 USB cables to make a USB A to USB A cable since most of us don't really have those laying around and the microUSB that came with the cam will not work.

The quality also seems pretty good. I would say it's comparable to the C920.

It does work with the Pi out of the box with no settings needing to be changed. I agree that the quality does look pretty decent.

Hi AHP, I just tried doing the same and the Wyze cam v2 works fine with my Windows 10 laptop but when I connect it to my raspberry pi running the latest octopi image it doesn't recognize it. I tried the lsusb command and it doesn't show anything extra when I plug the camera. I tried with 2 raspberries and no luck.

Any clues?

Since you said it works with Win10, I'm assuming you are using the correct USB A to USB A cable for both. If it works there, then it should work on the Pi, but I have no way of confirming that since I'm using a PC. But others have reported that it works with the Pi.

Thanks for the feedback. Still no luck here. What raspberry pi model and power supply are you using?
Thanks

Using the Xiaomi Xiaofang as a reference for the Wyze V2 USB camera capabilities, I was able to get octoprint to see a stream using the following 'camera_usb_options' options in the 'boot/octopi.txt' file:

"-r 1920x1080 -f 10"

  • Camera seemed to support different resolutions than 1080p (I tried 384x216 and 720p and they worked...(Edit) but entering 640x480 resulted in a 640x360 image). Entering different frame rates seemed to work.

My current challenge is with spaghetti detective...as soon as I install the plugin, connect my token, and restart the octoprint server, my previously working stream breaks with a Webcam stream not loaded error. Removing the token and restarting the server doesn't fix things. Rebooting the RPI gets the stream back.

Any ideas anyone?

(Edit) I've also tried the resolution to 640x480 to no avail.

@boxedlunch I connected the Wyze Cam v2 to Windows 10 as part of my troubleshooting and I see the camera app only shows 3 resolutions: 1920x1080, 1280x720, and 640x360.
@CheeseMcGee Can you tell me what version of Raspberry Pi and what power supply are you using?
My raspberry doesn't recognize the Wyze Cam v2, it doesn't show up when I execute lsusb but it does work with Windows. I wonder if my power supply is causing the trouble. It is already powering a dual relay I use to control the printer and lights. Maybe there is not enough power left to power the camera. I do see the blue+amber LED blinking though.

Tested on Raspi 3B Rev 1.2, Octopi 1.4 using a 2A USB power supply. WiFi being used. Have the following plugged in to usb: logitech unifying receiver, ender 3 controller, wyze v2 cam.

lsusb command on the pi gives me the following output:
Bus 001 Device 005: ID 0403:6001 Future Technology Devices International, Ltd FT232 Serial (UART) IC

If the camera's working in windows, I'll assume that you have the firmware updated and that you have a working USB-A to USB-A cable.

Hey thank you all very much for all the help.
I was able to solve the issue. It was my USB cable (soldered 2 cables together). Apparently the second half of the cable was too thin and was causing enough voltage drop to prevent the camera from working. After I realized this I removed that part of cable and soldered the thicker wire directly to the 2nd USB A connector.
Once I got a working cable I was able to use it with octopi v0.17.0 on both a Raspberry PI 4 and a 3b without changing any settings.

I am assuming no, but is there anyway to get the Night Vision / IR to work for Octo? I got super excited flashing it over and having a 1080p view on my printer, but bummed when night vision didn't work. After thinking about it I wasn't sure how I expected It to work, but man I would love to turn the printer light off at night and still capture my time lapses.

Is this off for good? I managed to get the camera to work on Octo, but the IR does not work. I may revert setting back and use APP, I kinda want the ability to see the print even at night.

According to Wyze, all you need to do is drop the firmware onto the root directory of the memory card, plug the memory card into an unplugged Wyze Cam v2, and then hold the setup button while restarting to flash the firmware onto the camera and reboot it as a webcam McDVOICE

For anyone looking for settings, I finally took some time to optimize the settings and they work great. I'm currently running at 1080 with no problems with the webcam firmware. Make the following changes to the /boot/octopi.txt file.

image

I just got this working! Here's what I did:

  1. Install USB Webcam firmware provided by Wyze
  2. Go into the octopi code via a text editor and find the txt file dealing with the camera. Delete the "#" in front of where it says "camera=auto". Save the file and reinsert your sd card into your pi.
  3. for some reason on boot I got an error saying it couldn't start the webcam daemon according to user specifications. To fix this, I powered off the pi, kept the camera plugged in but unplugged the printer. Powered up the Pi then reinserted the printer cable. (Not entirely sure why this worked)
  4. make sure you do not have the WebCam streaming plugin installed as this seems to cause a conflict with the camera feed showing up in the control tab.

Note: these were my troubleshooting steps. So its quite possible that one or more of these steps aren't necessary. But I'm not changing anything back since it seems to be working now. After I got the Pi to recognize the camera in the webcam test, it wouldn't show up in the control tab. This was fixed by disabling the streaming plugin.

Hope this helps!

My Pi 3+ is not detecting my Wyze camera even though it works with Win 10. When I run lsusb, there is an extra device when the camera is plugged in.

Bus 001 Device 006: ID 18d1:0001 Google Inc. Onda V972 (storage access)

The whole list, including version numbers:
OctoPrint version : 1.4.0
OctoPi version : 0.17.0

pi@octopi:~ $ lsusb
Bus 001 Device 005: ID 18d1:0001 Google Inc. Onda V972 (storage access)
Bus 001 Device 004: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I found this using dmesg

[ 602.964450] usb 1-1.1.2: Manufacturer: Ingenic Semiconductor CO., LTD.
[ 602.964459] usb 1-1.1.2: SerialNumber: Ucamera001
[ 602.988457] uvcvideo: Found UVC 1.00 device HD USB Camera (18d1:0001)
[ 603.301723] uvcvideo: Failed to query (GET_INFO) UVC control 6 on unit 2: -32 (exp. 1).
[ 603.331953] uvcvideo: Failed to query (GET_INFO) UVC control 9 on unit 2: -32 (exp. 1).
[ 603.358117] uvcvideo: Failed to query (GET_INFO) UVC control 4 on unit 2: -32 (exp. 1).
[ 603.378929] uvcvideo: Failed to query (GET_INFO) UVC control 11 on unit 2: -3 2 (exp. 1).
[ 603.407636] uvcvideo 1-1.1.2:1.0: Entity type for entity Processing 2 was not initialized!
[ 603.407652] uvcvideo 1-1.1.2:1.0: Entity type for entity Camera 1 was not initialized!
[ 603.408450] input: HD USB Camera: HD USB Camera as /devices/platform/soc/3f98 0000.usb/usb1/1-1/1-1.1/1-1.1.2/1-1.1.2:1.0/input/input2
[ 603.450929] usb 1-1.1.2: Warning! Unlikely big volume range (=10240), cval->res is probably wrong.
[ 603.450948] usb 1-1.1.2: [5] FU [PCM Playback Volume] ch = 1, val = -7168/3072/1
[ 603.453570] usb 1-1.1.2: Warning! Unlikely big volume range (=3072), cval->res is probably wrong.
[ 603.453585] usb 1-1.1.2: [6] FU [Mic Capture Volume] ch = 1, val = -1536/1536/1
pi@octopi:~ [ 9.171836] usb 1-1.1.2: new high-speed USB device number 5 using dwc_otg-bash: [: missing `]' pi@octopi:~
[ 9.302798] usb 1-1.1.2: New USB device found, idVendor=18d1, idProduct=0001, bcdDevice= 3.10 initialized!
[ 9.784615] uvcvideo 1-1.1.2:1.0: Entity type for entity Camera 1 was not initialized
[ 9.784813] input: HD USB Camera: HD USB Camera as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.2/1-1.1.2:1.0/input/input0
[ 9.784950] usbcore: registered new interface driver uvcvideo
[ 9.784953] USB Video Class driver (1.1.1)
[ 9.826548] usb 1-1.1.2: Warning! Unlikely big volume range (=10240), cval->res is probably wrong.
[ 9.826558] usb 1-1.1.2: [5] FU [PCM Playback Volume] ch = 1, val = -7168/307 2/1
[ 9.828538] usb 1-1.1.2: Warning! Unlikely big volume range (=3072), cval->res is probably wrong.
[ 9.828545] usb 1-1.1.2: [6] FU [Mic Capture Volume] ch = 1, val = -1536/1536/1
[ 9.829103] usbcore: registered new interface driver snd-usb-audio
[ 10.981852] uvcvideo: Failed to query (GET_DEF) UVC control 6 on unit 2: -32 (exp. 2).

I have a stock USB-A to USB-A, not something I made. I even tried using power from the Wyze power supply. Can somebody show how their Wyze cam is listed please?

Thank you for your help.

I had the same exact thing tonight when I tried for the first time. Then I carried out the edits to the /boot/octopi.txt as is mentioned above, rebooted and it worked like a charm right away! Hope you it works out for you!

It may be super obvious to everyone but me, but you can't leave the micro-usb power cord plugged in after you flash the WyzeCam V2 webcam firmware. I had the micro-USB power cord plugged into a USB charger and my USB A to USB A cable into my Raspberry Pi 3B and it never worked right. Finally thought to unplug it the micro-usb cable, left the USB A cable in, and rebooted the OctoPi and it worked just fine after that. I had modified my octopi.txt file as per CheeseMcGee's suggestion, so I suspect that helped as well.