No more working Filament Sensor Plugin for Octoprint?

What is the problem?

I really need to have a filament sensor connected to my UMO+ but after some reading here I got the impression, many filament-sensor plugins for Octoprint do not work any more!
Ist that true and if so, can someone please point me to a plugin that really IS working?
The type of sensor wouldn't matter as I still haven't got one yet. So I'm still free to choose.

What did you already try to solve it?

So far I have just searched the net for information.

Have you tried running in safe mode and if so did it solve the issue?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

No Logs available

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint Version 1.3.11, Ultimaker Original+, Windows 10, Firefox

Hello @basteluwe!

This should run quite well:

1 Like

Some of them may not be compatible to 1.3.11 anymore, this could be another of your issues. Maybe you want to try updating?


Thanks for your replys so far.
Actually I was reading this very long topic about filament sensors and at the end someone suggested Enclosure-Plugin would do the job. But others said, they tried and it didn't work either.
Well, I guess I have to try for myself.

And yes, updating the OctoPrint SW seems a good idea!

Rgds Uwe

I have just setup Filament Sensor Simplified v0.2.0 which works well. Note if you have tried v0.1.0 I would uninstall then reinstall v0.2.0 as I had a problem upgrading.

1 Like

I am doing whatever it takes not to simply run long wires to any fan headers in the worker expecting the walled in area module could deal with it by then!

I have recently added a runout sensor (just using a micro switch) to my Ender 3. I have a description of what I did and used here:

So far it has worked without any issues.