Not Able to Connect to WiFi with Octopi

octoprint.log (293.6 KB)
I have been trying connect Octoprint to my wifi network. I originally set up OctoPi 0.17 on a new RPi 4B (4mb) at my home location where I have a very robust internet connection (1 Gbps). Octopi was quickly recognized on that network and I was able to use it with my 3D printer and web cam with no trouble. I have since moved the printer to another location with a different network. I modified the octopi-wpa-supplicant.txt with the new network login data using Notepad 3. The pi booted up but the new network has not been able to see the pi (octopi). I have gone into my router and there is no entry for the pi. I have used Angry IP Scanner which also does not see it. I then tried to connect to this new network with a different raspberry (also a RPi 4B) that has the standard Raspberry OS loaded on it. It connected with no problem. I can connect to the network and this regular pi is recognized as raspberry.local in the IP listing of Angry IP Scanner and in my router device file. I also tried to connect the first Octopi raspberry via ethernet and I was able to successfully connect with OctoPrint and connect to my 3D printer and see my web cam. However, I cannot connect by wifi when using the octopi OS.

Things I've tried but with no success:

  • moving the pi to different locations including right next to the router
  • started over with a new micro SD card and flashing a new octopi image
  • carefully double-checking my wifi settings in octopi_wpa_supplicant
  • carefully double-checking my router settings
  • ssh into octopi.local and checking ifconfig wlan0 and iwlist wlan0 scan

I have a Netgear Nighthawk RAX80 router. I'm using OctoPrint version 1.3.12. My computer is running Windows Pro 10. The network is Judgernet1. Software and firmware are all up to date. It seems there is something wrong with my octopi.txt file or some other configuration file since another standard raspberry was able to connect to the wifi network but the octopi raspberry cannot. I am not sure where to get logs that you might need so I am uploading everything I can think of including the OctoPrint log. I was advised by John_Mc to provide ifconfig wlan0 and iwlist wlan0 scan.

pi@octopi:~ $ ifconfig wlan0
wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether dc:a6:32:04:9a:b7 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

The iwlist is very long so I am uploading a png

. Not sure what else so please advise if you need something in particular. Any help will be greatly appreciated.

What did you already try to solve it?

Logs (syslog, dmesg, ... no logs, no support)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

can you attach your /boot/octopi-wpa-supplicant.txt May be as simple as not having the country set in the file. Obviously change the SSID and Password in the file so we don't see yours
Oh, /var/log/messages would help as well, as the wifi connectivity is a system function, not Octoprint

I have attached the 'supplicant file. I am not sure how to access the /var/log/messages. I am still new at this. Let me know and I will do it. Thanks.

Robert Ray

(Attachment octopi-wpa-supplicant.txt is missing)

I have attached the supplicant file. I am not sure how to access the /var/log/messages. I am still new at this. Let me know how and I will get it for you. Thanks.

Robert Ray

For you live in the US, you have to comment the line country=GB # United Kingdom
Put a # in front of it.
The software uses the first entry, that is not commented.

Thanks for catching that. I corrected it in my original file (and triple -checked everything else) and rebooted. However, this pi still is not visible to my network.

Robert Ray

I hate the way the default file is set up. WAY too many comments etc that can get hosed.

Mine I pared down to:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


In the output of your iwlist wlan0 scan command, you will see a number of "blocks" each starting with "Cell 01", 'Cell 02", etc. Each of these blocks is a WiFi network that your Pi can see. About 5 lines down from the "Cell 0x" line, you will see a line that starts with "ESSID:" This is the name of the network that your Pi can see. (For example, Cell 01 is shown as ESSID:"JUDGERNET1_2GEXT").

If you can see the name of your network in this list, that tells you your Pi can see the network to which you are attempting to connect.

A couple of lines above the ESSID line in each cell, you should see a line which looks something like: Quality=67/70 Signal level=-45dBm . This gives an indication of the signal quality and strength. Unfortunately, I've been away from this long enough that I no longer remember what is considered "good" for these numbers. (Hopefully, if you see the network you want, and report those numbers, someone here can tell you whether they are good or not.)

At any rate, if your Pi can see your network, that tells us that the problem is in logging on, not due to the signal being blocked or your Pi malfunctioning. THat will help focus any further troubleshooting tips. (The fact that you can see ANY network is an indication that your Pi's WiFi is OK.)

While waiting for more in-depth troubleshooting, I'll repeat two of the more common problems here (as noted in the WiFi setup and troubleshooting guide).

One of the most common problem people run into is not using an appropriate text editor to edit the file. Some text editors make subtle changes (or not so subtle ones) rendering the file unusable by the Pi. As mentioned earlier, I have been away from this for a while. I am unfamiliar with NotePad3 and whether it causes problems or not. Notepad++ for Windows is know to work, and is free. Unless someone on here comments that Notepad3 is known to work, you might try again using Notepad++. You will need to start with a clean copy of the supplicant file; don't just re-edit the file you have already edited.

A weak power supply: these are the cause of SO MANY issues with the Pi, particularly when WiFi or Bluetooth, or some external load is being powered by the Pi. The problems caused by a weak power supply are often intermittent, so they can baffle you when you try to trouble shoot.. If the power supply you used with your other Pi worked, try it on this one.