Octolapse and Ender 3 Issues


#1

Just to be clear I am new to 3D printing and Octoprint and Octolapse...First off, I am having a blast with my new printer and it wouldn't be so without developers like these guys, thanks so much!

My issue, I have not been successful in really stabilizing my videos. Here is a link to my latest.

In this vid I have Stabilization set to Fixed - Extruder at Center Left. While I got output the snapshot is not occurring where I would expect it to (center left) and there is wobble in the Y axis and the first few frames are all over the place. I have played with adding M82 and G90 to my starting GCODE and setting the Axis mode to Explicit but that does not seem to resolve my issues. I suspect a timing issue or perhaps an issue in my printer profiles somewhere but have run out of things to look at.

Thanks in advance for any assistance!

Chris


#2

Here is my starting GCODE
M75 ; Start Print Timer and Engage Fil Sensor
M82
G90
G28 ; home all axes
G28 Z ; home Z to get more accurate Z position
G29; EZABL mesh generation
G4 S10; wait for heaters to recover
M117 Purge extruder
G92 E0 ; reset extruder
G1 Z1.0 F3000 ; move z up little
G1 X10 Y20 Z0.3 F5000.0 ; move to start-line position
G1 X10 Y100.0 Z0.3 F1000.0 E15 ; draw 1st line
G1 X0.4 Y100.0 Z0.3 F5000.0 ; move to side a little
G1 X0.4 Y20 Z0.3 F1000.0 E30 ; draw 2nd line
G92 E0 ; reset extruder
G1 Z1.0 F3000 ; move z up little


#3

Spiral_2_trimmed.gcode (2.6 MB)

My gcode....I trimmed the file down so I could upload it.


#4

Update - I edited Snapshot Layer Change enable Trigger on Z-hop Only and this has helped somewhat, not perfect but better. My first 4 layers are not predictable however after layer 4 the snap shot performs where I expect it to - i.e. Extruder and Center Left. I tested this back and forth and this setting does cause a problem for me. Any thoughts on how to get my first 4 layers to work properly?


#5

I believe there is a setting in Octolapse for the delay in miliseconds. You can try changing that value and see if it helps.
It may also be beneficial to set up the printer info in Octoprint- ie: speeds


#6

Thx Ironjoe. I played around with the Snap delay lasy night and didn't see a difference. The default is 125ms, I changed this to different values all the way to 300ms and all the way down to 0 and didn't see a difference. When you mean printer speeds are you referring to what is defined in the Octoprint Printer Profile? I was under the assumption this was just for the Control Tab function. In Octolapse I have the following speeds defined...These match my Simplify3D settings best I can tell.
Movement Speed - 4800
Retraction Speed - 2400
Detraction Speed - 2400
Z-Axis Speed - 1002


#7

I assume you have already set the z-hop height set in Octolapse to 1mm.
Out of curiosity, have you tried a print at .2mm? All I can see in the Gcode is .19mm layers....I wouldn't think it should matter though


#8

That is odd...My Simplify3D says .2mm layer height. Octoprint default for Z-hop was .5mm on my CR-10 settings (which I am using). I have tried .2 and .1 but not 1mm...I can try that. Thx


#9

The beginning Gcode says .2mm layers and extruderRetractionZLift,1; but in the running code, it says .19mm

G1 Z1.190 F1002 <-----1mm Z hop from 0.19mm
; inner perimeter
G1 X94.645 Y109.911 F4800
G1 Z0.190 F1002 <-------- 1mm return to .19mm


#10

Oh I get it...I have Layer 1 set at 95% in S3D to help with bed adhesion. I also have First Layer Width at 120% an Speed at 25%...could this be the source of my problems?


#11

The layer height shouldn't make a difference in all reality... take a look at https://github.com/FormerLurker/Octolapse/wiki/Snapshot-Profiles


#12

Thx Ironjoe for all your help! I finally got a good capture. My start GCODE has a lot of pre print steps as well as the ABL script, so that was causing some of my issues (I'll have to edit those out I guess as there are a few layer changes in there), as well as I added a GCODE trigger that really helps!


#13

@chrishet,

I believe your initial issue was a bug in Octolapse. The short story is that G92 is messing with snapshot timing when using absolute extrusion. The long story is that G92 seems to send a location back to Octoprint, similar to an M114. In some situations this confuses Octolapse into thinking the printer is in the snapshot position when it really isn't. The workaround is to switch to relative extrusion within your slicer. Alternatively you can use a development version or wait until the next release appears (hopefully it will be soon). Let me know if you'd like to try a newer version. I am looking for testers.


#14

Thanks Brad. I really appreciate all the work! I’ll be more than happy to help out and test. I am also going to experiment with a DSLR. Just let me know how I can help out. FYI, I am heading to Europe on Sunday for 10 days – a little much needed vacation and some photography.

Best regards,

Chris Hetlage


#15

@chrishet,

You can use this link to install the dev commit via the plugin manager. You must be running Octoprint 1.3.9 or above to use this version.

I advise you to export your Octolapse settings first (Settings (wrench)->Octolapse->Download Settings) since there may be an issue within the settings migration routine. After you install and reboot and clear your cache (ctrl + F5), if you are missing your printer or camera profiles, send me your exported settings.json file and then click:
Settings ->Octolapse->Restore All default Settings

Next, revisit your printer profile, select your preferred slicer and copy in all the settings. You may see some warnings below the slicer settings if your speed settings aren't unique (more on this later). If you want you can move them up and down by 1 mm/min or 0.1 mm/sec in both your slicer and in Octolapse until all speeds are unique.

Finally do a test print with the 'Layer Change - compatibility' snapshot profile and the 'Test Mode' debug profile. If it all looks good you should be ready to go!

IF you made all of your speeds unique you can also try out the 'Layer Change - High Quality' snapshot profile. This should eliminate virtually any artifacts that might have been visible when using the compatibility profile. It's possible that Octolapse misses some layers when using this mode if you have cooling features that slow down fast (or first) layers, but it's a pretty good trade off IMHO.

Enjoy your vacation! Where in Europe are you heading?


#16

Cool...will give this a try and report back. We are heading to Rome for 4 days then on a cruise for a week. Lots to see!