Octolapse doesnt work for me can anyone tell me what im doing wrong


#1

hey guys ive been trying to use octolapse on my cr-10 it never takes a picture ive tried a few different types of animations and settings but it always says the same thing

waiting for all axis to home and shows 0 for the number of snapshots.

I was also wondering is this something seperate to timelapse and does it have to be disabled for octolapse to work?


#2

Hi! Can you post your gcode file for me? Also, if you turn on the 'Position State' info panel in the tab, it gives more detailed info about the current state of Octolapse's position detection. My guess is that it doesn't know the XYZ axis mode, which seems common for CR-10 printers. They don't put a G90 in their default start-up gcode like they should IMO.

Look in your start/end gcode for a G90 command. If there is none, go into Octolapse and change 'XYZ Axis Mode' to 'Absolute' and try another test print. Without seeing your gcode that is my best guess.

FYI, I'm thinking of changing the default CR10 profile to deal with this issue. I've been resisting setting 'absolute' as the default since it's possible someone sends a G91 before your print starts, which would mess things up.

Also, take a look at this troubleshooting page, which could help too: https://github.com/FormerLurker/Octolapse/wiki/Troubleshooting

Let me know if that helps.


#3

Hi. I too have a CR-10S that stubbornly refuses to create any snapshots. I have run a small part using Octolapse' Test Mode and this proved fruitless. I have noted at https://github.com/FormerLurker/Octolapse/wiki/Troubleshooting that the likely cause is a lack of G90 code in the startup code of my printer profile. Using Cura v3.3.1 I can edit those codes which are as follows.

Start G-code

G28 ;Home
G1 Z15.0 F6000 ;Move the platform down 15mm
;Prime the extruder
G92 E0
G1 F200 E3
G92 E0

End G-code

G91
G1 F1800 E-3
G1 F3000 Z10
G90
G28 X0 Y0 ; home x and y axis
M106 S0 ; turn off cooling fan
M104 S0 ; turn off extruder
M140 S0 ; turn off bed
M84 ; disable motors

Would the fix be as simple as adding a G90 to the startup code and if so, where?

Here is the gcode for the small part I tested with.

CR-10S Levelling knob.gcode (2.8 MB)

plugin_octolapse.log (381 Bytes)


#4

Before I changed anything in the startup code I tried your fix. This has worked fine. Is it worth changing the startup code of my printer profile?


#5

I think its worth changing the startup gcode. Mine starts with:

M107                     ; disable fans
G21                      ; set units to Millimetres
G90                      ; absolute positioning
M82                      ; set extruder to absolute mode
G92 E0                   ; set extruder position to 0

You should place the G90 before any commands that set X,Y,Z, or E.

As you can see in the end G-code you posted, the G91 precedes the relative retract and the relative Z move followed by G90 before the move to absolute X = 0, Y = 0.


#6

Thanks @b-morgan. Change made, I put it at the top before the "home". I'll test it on the next print.


#7

@b-morgan, thanks for that! I wonder why so many default slicer profiles don't set absolute/relative coordinates before printing.