Octolapse Error caused by viewing camera via control

I run Octopi (Raspberry Pi image) with a Pi Cam V2. I often watch the print start from the Control tab in OctoPrint. However, this causes OctoLapse to error every time. Strangely enough when this happens the print job doesn't start.

  1. Has anyone else experienced this issue?
  2. Is there a work around, I'd like to be able to use the Control view concurrently with OctoLapse.
  3. I do not want OctoLapse to kill a print job. Is there a configuration element that will allow OctoPrint to proceed even if OctoLapse fails?

Here's my hypothesis, when the Control view of the camera is active in OctoPrint it has exclusive access to the connection and prevents OctoLapse from connecting to the camera service on port 8080.

Supporting this theory is that when I access the http service for the camera (e.g. OctoLapse generates the same error. I find this strange as an HTTP service (apache or whatever) should allow multiple connections. OctoLapse is configured to use the loopback address (

For anyone experiencing issues with OctoLapse here's my notes:
I use Cura, added G90 (Absolute XYZ) to the printer gcode. This moves the bedplate and nozzle to the position specified in OctoLapse (e.g. Left Back). It is configured to trigger for each new layer. This way you get those nice timelapse videos where everything is stationary. I found some good explanations on how to do this on YouTube.

It's late, I'll provide more specific s and details later. Thank for any help with this issue.

Very strange. I've never heard of this before.

Octolapse DOES have an option to continue prints if they fail the Octolapse pre-print tests. I have no idea why your stream doesn't support multiple connections. Can you open two browsers and view the control tab in both? If not, something else is going on.

Try using (notice the ending backslash) or as your base address in Octolapse and see if that helps. Also, make sure your snapshot address is this: {camera_address}?action=snapshot

Yes, my snapshot address is: {camera_address}?action=snapshot
http://X.X.X.X:8080/?action=snapshot displays a single image

Things that may contribute to the complexity:
I have a 3.5" Waveshare touch LCD installed on the Raspberry Pi
I installed TouchUI which loads the web browser and displays the OctoPrint interface on the LCD.

Appreciate any help, thanks.