Octolapse issue - Error Spam Attack when using Octoprint Settings --> GCODE Scripts


#1

Hi FormerLurker,

Before I begin, Thankyou SO MUCH for Octolapse!
It is an amazing addon that works so well and is so feature rich!
It's my number-one must-have addon!

Letting you know I've found a weird issue with Octolapse...
If I take away my start / end GCode scripts from Cura/Simplify, put them into Octoprint (Octoprint Settings --> GCODE Scripts) and use Octoprint to perform my start/end GCodes, Octolapse has a major Error Spam Attack!
The screen pops out an error popup for every line of GCode after the initial start GCodes, filling the screen with error popups.

Error message "Octolapse position Error.
Position Coordinates
(X:None, Y:None, Z:None E:10368037) are out of the printer area! Cannot resume position tracking until the axis is homed, or until absolute positions are received."

The "X:None, Y:None, Z:None" always stays the same through all the error popups, only the E changes.
In my start GCodes, my axes are all homed and I'm using absolute positioning.

With the start/end GCodes embedded into the GCode file from Cura/Simplify, Octolapse works great.
When I remove the start/end codes from Cura/Simplify, re-slice, put the start/ends into Octoprint and run - Octolapse has a panic attack.

My Octoprint GCodes:

Before print job starts
M190 S50 ; Turn On Heated Bed and wait till warm.
M104 S205 ; Start extruder heating and continue (no-wait)
G28 ; Home
G29 ; Auto Bed Level
G1 X10 Y380 F4000; move to back left corner
M109 S205 ; wait for extruder temp to be reached
G1 Z0.4 ; move platform close to nozzle
G1 X60 E10 F2000 ;Extrude Anchor
G90 ; Absolute positioning (added later to ensure absolute - did not help).

After print job completes
M107 ; Fan Off
M106 S0 ; Turn Off Cooling Fan
M104 S0 ; Turn Off Extruder Heater
M140 S0 ; Turn Off Heated Bed
G91 ; Relative positioning
G1 E-1 ;retract the filament a bit before lifting the nozzle
G1 Z+3
G90 ; Absolute positioning
G28 X0 ; Home X to take nozzle away from print
G1 Y370 ; Move Bed Forward to Present Part
M84 ; Disable Stepper Motors

If you're able to fix this issue, it would be greatly appreciated!

Thankyou for your time.

Dogbert.


#2

The problem looks to be that the G90 you added comes after several absolute moves:

G28 ; Home
G29 ; Auto Bed Level
G1 X10 Y380 F4000; move to back left corner ** Absolute Move
M109 S205 ; wait for extruder temp to be reached
G1 Z0.4 ; move platform close to nozzle ** Absolute Move **
G1 X60 E10 F2000 ;Extrude Anchor ** Absolute Move
G90 ; Absolute positioning (added later to ensure absolute - did not help).

Try this instead:

G90 ; Absolute positioning - before any absolute movements
G28 ; Home
G29 ; Auto Bed Level
G1 X10 Y380 F4000; move to back left corner
M109 S205 ; wait for extruder temp to be reached
G1 Z0.4 ; move platform close to nozzle
G1 X60 E10 F2000 ;Extrude Anchor

I also don't see an M82/M83, and can't tell if your gcode is sliced for relative or absolute extrusion. You should be able to tell in one of two ways:

  1. Check your slicer settings. There should be an option somewhere indicating relative/absolute extrusion.
  2. Examine your gcode to see if the E parameters within any G0/G1 commands continually increase (M82) or if they appear to be small, but do not not continually increase (M83)

That should go before or after your G90 for best results. Let me know if that helps or if you have any additional questions.


#3

Thankyou for the quick reply!

I put the G90 (and even an M82 to be double sure) at the start of the script as you suggested, and also double checked whether my slicer is on relative or absolute - definitely set to absolute.
Confirmed with the gcode - E continually increases throughout the file and X/Y goto absolute positions.
No change - still getting numerous popups until I stop Octolapse.

Is there anything else I can try?


#4

Can you post another pic of the errors? Perhaps we solved one issue only to discover another? I'm thinking it's probably a print volume issue.


#5

I hope this pic is OK.
It's really difficult to get a good screenshot because the go away and move about almost as fast as they appear.


#6

Hey, was the GCode you gave me earlier from Octoprint? The changes you made were still necessary, but there is a known issue with OctoPrint start/end gcode at the moment that either requires some changes to OctoPrint or some work-around I haven't thought of yet.

If the start/end Gcode IS in OctoPrint, try moving it to your slicer, removing it from OctoPrint, and re-testing. If that works you can either leave the start/end Gcode in your slicer for now, or you can wait for a patch, which will be released as soon as possible.

Please let me know if that works, or if you need more information!


#7

Yes, that GCode was from Octoprint.
Yep you are correct, when I move the start/end codes back to to my slicer, Octolapse works fine. :slight_smile:

No worries, I'll leave it in my slicer for now.
Thankyou for letting me know. :slight_smile:

And Thankyou again for such an Awesome plugin! :slight_smile: