Octolapse not triggering next layer change


#1

I have installed Octopi with Octolapse plugin with the latest versions. Everything seems to be working well except I can’t get the Layer trigger to change. It just sits at 1. As a result it only ever takes 1 screen shot. It shows the absolute positions of the x,y,z,e changing and the G code viewer is showing multiple layers. The position state info panel shows layer:1 height: 15mm (not sure what this means).

Any ideas why it isn’t figuring out that it is printing up the layers or other reasons this isn’t working?

Many thanks for any help, Craig


#2

Update: ok it seems to be triggering layers every 0.2mm but only starts doing this at 15mm height. Not sure why but I will keep digging.


#3

Update 2: I am new to this so don’t understand g-code very well but I think the starting g code sets the z height at 15mm so the camera doesn’t think it is changing layers.

The code is:
G91
G28
G1 z15 F6000
G92 E0
G1 F200 E3
G92 E0

Could this make Octopi think the absolute height is 15mm until the nozzle goes above 15mm?


#4

Update 3: for my next print it worked. Sorry, don’t know why but consider this solved, unless I come up with another update!


#5

Hi Craig! It looks like your printer is priming at 15MM, so Octolapse thinks the first layer is at 15MM (because reasons, lol!) This would cause the following to happen:

  1. Octolapse takes a snapshot right before the initial prime.
  2. Octolapse will not take another snapshot until extrusion is detected ABOVE 15mm.

I have fixed this in the default settings In the latest release candidate (v0.3.0rc1) by setting the priming height for all default profiles to 0.75MM. This tells Octolapse not to start layer tracking until it detects extrusion BELOW this height (extrusion at this height will not count).

In summary, set your priming height to 0.75. It just needs to be above your maximum layer height but at or below the height at which your printer is priming (15mm by the looks of your gcode).

Edit: fixed some placement errors.


#6

Thank you for explaining this. I am new to 3D printing so am still learning the basics. So should I just change z to 0.75 instead of 15 in the above code or perhaps add an extra g1 z 0.75 at the end? What exactly is priming - is that making sure the nozzle is heated and done an initial wipe before printing?


#7

No, you shouldn't change your gcode at all. Do the following:

  1. Click the settings wrench in OctoPrint
  2. From the menu in the left hand side, scroll to the bottom and click 'Octolapse'
  3. Select the 'Printer' tab on the right hand side.
  4. Find your printer profile and click the 'Edit' button.
  5. Scroll to the very bottom and change the value for 'Priming Height' to 0.75.
  6. Click 'Save'

That should do it! Let me know if it works for you.


#8

Thanks Brad. A little knowledge is a dangerous thing! This is working fine now. Thanks for the help.