Octolapse on windows Camera issues


#1

So I've installed octoprint on windows. I hooked up the octoprint cura plugin as well and, had a successful print.
I then went to install the octolapse plugin and things went a little haywire.

Following the website's windows tutorial everything seems to be working until I go to octolapse itself. The webcam is setup that when I run the tests in octolapse's Webcam setting tab everything shows up. The cameras feed from yawcam also shows up in the octroprint controls tap. Yet under the octolapse tap nothing seems to be available.

Is there something im missing or something missing from octolapse for windows?


#2

That area where it says 'Welcome to Octolapse' won't show any snapshots until you start a print and Octolapse takes a snapshot. It just shows the most recent snapshot taken by Octolapse.

You're not the first person to assume things weren't working at that point (unless I am mistaken), so I need to update this functionality to make things a bit more clear I think.


#3

Its definitely not functioning correctly ohh how I wish it was just a simple overthinking it problem.
So I started a fresh set of tests on another pc.
First test was to do a clean install of everything octoprint itself, Cura and yawcam and see if they function.
Octoprint and cura worked as intended even the native timelapse feature of Octoprint functioned perfectly taking pictures saving them and turning them into a video.

So then I went onto to the install of the octolapse plugin.
Octolapse doesn't seem to acknowledge the camera for some reason and I run into errors.

3

4

It seemed to disable the functioning part of Octoprint as the native timelapse feature no longer worked.
Opening up octoprint in IE and Firefox had some strange results too, the octolapse plugin tab is non existent as if the feature was not installed yet when opened in chrome it shows up just fine.
To me and my limited knowledge it seems that the octolapse plugin is not installing correctly.
So I retested it.
Starting again on another computer a fresh install of all the base software and features yielded the same results. Somethings not quite right with the Octolapse installation.
I think Im going to try doing an install of octolapse from each browser to see if maybe the browser is causing an installation failure.

One additional thing to note, is I must start the octoprint server first and connect it to the printer before opening cura, if this is done in any other order I get "tornado.access - Warning - 409 GEt /api/printer (::1) 2.00ms" "octoprint.server.util.flask - Debug - App sessions after cleanup {} ..... -This spams the consol in cmd prompt endlessly.


#4

Sorry about the earlier misdiagnosis, I can see that there are other issues at play here. Perhaps this has something to do with Yawcam. I do test with yawcam pretty frequently, but not as much as mjpgstreamer. Can you take a pic of your webcam settings in the octolapse camera profile (specifically the base and snapshot address)? That may shed some light on the problem.

Also, I can see that you are using Octolapse 0.3.1. There have been several enhancements specifically regarding webcam testing and verification, so it's possible (though a bit unlikely) that your problem has been fixed within the latest rc/devel branch. If I can't see anything obviously wrong with your settings maybe you'd be willing to try a pre-release?


#5

This is my camera settings from octolapse When a Test is run, Yawcam acknowledges that a "viewer" has connected.

I then went to the octoprint webcam settings tab and this popped up. "Camera Test Failed - An exception of type:<type 'exceptions.MemoryError'> was raised during the test! Error:" (im assuming from the test I had run in the octolapse camera setting tab as I hadn't clicked anything in the octolprint webcam tab )

These are the settings from the webcam tab, all 3 tests there confirm that camera is working without any error messages

And I would be happy to try a pre - release version if it might help solve the issue. Though I'm unaware of how to do this properly.


#6

Well, I think I see the problem (thanks for the images, they really helped)!

The error you are getting is because your camera URL is for a stream, not for a single image (I need to update the error message obviously). Try these settings:

Base Address:
http://172.18.154.88:8081/
Snapshot Address Template:
{camera_address}out.jpg

Hopefully there are no typos there, but try the 'test webcam snapshot address' button in Octolapse and see what happens. Either way, let me know!


#7

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


#8

Yeah, it was flagged because "This new user tried to create multiple posts with links to the same domain". I cleared the flags, you should be good to go.


#9

Short version, stop linking to that third-party website. I've just manually uploaded your graphics to this thread.


#10

So the solution you provided about the base address change didn't seem to solve the problem. Do you have a link to the pre release candidate for octolapse that you suggested that may solve the issues? Also are there any special instructions for it that I may need to know before doing a regular plugin install?

Thanks again for the quick replies and help solving this particular issue.


#11

Even though I replied to your email request, I'm going to post here so others can follow along.

Let's first figure out why the camera address isn't working for you. Use the link I sent earlier (
http://{IP_OF_PI}:8081/out.jpg), and let me know if you see an image. FYI, the port (8081) is configurable within yawcam, so double check that first.


#12

This thread can be closed, I resolved the issue with a webcam driver reinstallation.


#13

Hi!

Before closing, could you please mark the thread as solved? Thanks a lot.


#14

@TWG/@GfX01 And also, the system knows if you are sockpuppeting.