Octolapse - Oozing


#1

Tried Octolapse on my 1.3.9 Octoprint (and it working great with my Prusa i3 mk3.
The only thing is that I get ozing and hairy prints. What setting should I change? I cant find it under my printerprofile. Or am I looking at the wrong place?


#2

Hi, I found this video on youtube. It might help you. I have not tried it yet. My enclosure with my webcam is not ready yet.


#3

Thank you, I will watch it when I'm at home and try :slight_smile:


#4

Hi @Martin_Tellblom,
meanwhile my enclosure is build and I tried Octolapse. No issues with oozing!
Tested both PLA and PETG with the settings recommended in the video.


#5

Seems like I can't use Octolapse now suddenly It wont heat the extruder or bed, just starting to try to print without heat if Octolapse is active


#6

@Martin_Tellblom, I would bet that 'Test Mode' is enabled, which strips all heating/extrusion/fan commands from your gcode. Check your 'Debug Profile' and set it to 'No Logging'. Let me know if that fixed things for you.


#7

Have now watch the video, used change a few settings.

First Thanks @FormerLurker - Test Mode was enabled

The picture below describes my problem. The model to the right is just printed without OctoLapse enabled, the one in the middle is the try with OctoLapse and the standard settings for i3mk3 (quite hairy :slight_smile: )

The last one to the left is with Octolapse but with 5 degrees lower temp on the second layer and up. It creates a lot less ozing but still more than I am pleased with.

Should I try to increase the retraction or what do you think?


#8

@Martin_Tellblom, there are a lot of artifacts on the Octolapse versions, even the 'better' one on the left. Can you export your settings.json file (OctoPrint settings (wrench)->Octolapse->Download Settings) and post your gcode? I'd like to verify your config to make sure there's nothing obvious.

However, I have to say, the one on the right looks spectacular. I can't get these results with my printer with or without Octolapse enabled, though it could have something to do with my MMU 1.0 bowden (hopefully I get 2.0 soon). Bravo.


#9

Hi @FormerLurker

here comes the settingsfile (renamed to .gcode so I could upload the file) and my gcode for my model comes in the next post.

This gcode is for PLA and has first layer 215C and second an after 210C, bed temp 65C.

I'm about to order the MMU2 any time now, I think that is a very nice addition, the only thing right now is the 40cm between the printer and the filamentspools that has complicated my IKEA LACK enclosure. But right now I'm printing ABS just fine without a enclosure so I don't really know if I need one. Will have to see when the Winter comes along.

Settings.gcode (73.0 KB)


#10

And the model G-code file

TimeLapseTest2.gcode (906.8 KB)


#11

Thanks, I'll take a look right after work. I have 3 other gcode/settings files to run though, so I can do them all in one sitting :slight_smile:


#12

@Martin_Tellblom, I just looked at your settings and I see that you are using V0.3.1. Nothing wrong with that version, but you'll be able to get much better quality with the pre-release if you're willing to try it out. I need some testers anyway. Let me know and I'll send you some instructions.

I do see that you need to adjust your travel speed (if you continue to use 0.3.1) for both XY and Z:

Movement Speed - should be 180 mm/sec (make sure you get the unit right! Octolapse supports mm/sec and mm/min)
Z-Movement Speed - Should also be 180 mm/sec. Your firmware will properly limit this speed for the MK3

I can recommend other things to improve quality in 0.3.1, but won't bother if you are willing to try 0.3.4rc1.dev2. Let me know!


#13

About the travel speed, 12000 (200mm/s) is what it says in Slic3r, that why I changed that value.

As a software developer myself I'm all in to try pre-releases :slight_smile: just tell me what to do


#14

Here is a link to the devel branch (it's a bit more recent than the latest pre-release): https://github.com/FormerLurker/Octolapse/archive/devel.zip

Normally I wouldn't recommend installing from the devel branch, but I'll be sure to keep it stable until I push out the next rc/devel release. Also, this version will track development RCs (rc/devel), release candidate (rc/maintenance) and master branches depending on your Software Update Plugin settings. If you switch to 'Development RCs' in the software update plugin you'll get a notification when I update the devel/rc branch :slight_smile:

Notes: You will lose your snapshot profile customizations. They will be replaced with new (better) defaults. Also, you'll need to edit your printer profile, pick your slicer and enter all the values requested. There are more settings to copy from your slicer now, but they should be easier to enter since everything is customized to match your slicer selection (drop down box at the top of the printer profile).

There is a new feature you might be interested in within the new snapshot profiles. It's called (tentatively) feature detection, and can be used to prevent snapshots over critical areas of your print (exterior perimeters, bridges, etc..). Check out the 'Layer Change - High Quality' trigger, which uses this new feature. It works by knowing what speed each feature will be printed at, so it helps if all of your slicer speeds are unique.

Check out this video where I walk through getting this configured, including getting the 'High Quality' snapshot trigger working. It's a bit long, but should be worth it.

Let me know if you have any trouble, and please report any issues here.

Thanks!


#15

Thank you, I will install this tomorrow when I'm back home


#16

Couldn't hold myself :slight_smile: Made the installation, and configured everything with different speed.

Tested Layer change - High Quaility and now it does not take any pictures at all (just one at the beginning). I can understand if it has problems with the small pipes but it should have taken some pictures on the bottom layes.....

There is something I haven't got right


#17

@Martin_Tellblom,

Somehow this dropped off my radar, sorry. My guess is you're running into the 'minimum layer time'. Most slicers have this setting to allow a given layer enough time to cool before starting the next. However, most slicers change the Axis speeds via F (e.g. G1 F1000) instead of by setting the FeedRate (can we get a feature request!), which totally confuses Octolapse. It doesn't know how long a layer was 'supposed' to take, so can't adjust the feature speeds. Odds are you won't get snapshots on these layers where the min layer time is hit.

You can turn this off in your slicer, but for prints like this it might cause a substantial impact. OR, you could turn it off in your slicer and just turn your feedrate down a bunch to compensate since most of these layers will likely take the same amount of time to print.

Let me know if that helps!


#19

I have now, with the help of your video, changed the settings in speed and so on and used Layer change - High Quaility with almost very good result. NO Ozing what so ever so thats very good but parts with thin walls it does not make any pictures.

It take snapshots every layer on the hexfigure but skips everything in the cone.
Some configuration I have missed I think


#20

Hi again! Thanks for trying again to make it work. I'm very happy that you noticed an increase in print quality since this feature was added for exactly that reason!

It looks like you have two perimeters + infill on these layers (as best as I can tell), so the default 'high quality' profile would normally take a picture either on the infill or the non-exterior perimeter. I know my last response is a bit old, but my suspicion is that you're running into 'Minimum Layer Time'.

As a test you could try settings 'Slow down if layer print time is below' setting (shown below) to 0 and reprint.

This could impact your print quality, but at least we'll know what's going on.

I don't think there's a way to work around this except to add an option to allow snapshot capture at an unknown speed, which will probably create oozing on these layers (I'll probably do this soon). That's why I'd like to see an option in Slic3r (and other slicers) to allow cooling to be controlled via 'Feed Rate' instead of by changing the F parameters.


#21

Thanks for quick reply, I'll try and get back to you