Octolapse plugin - can't save printer profile, while having Preety Gcode plugin enabled


Raspberry Pi 4 4GB, 5G Wi-Fi

OctoPrint 1.5.2
Python 3.7.3
OctoPi 0.17.0

Octolapse 0.4.1
PreetyGCode 1.4.2

Bug description:
User cannot save printer profile in Octolapse, while having PreetyGCode plugin enabled.

How to recreate bug:

  1. Enable PreetyGCode plugin
  2. Go to Octolapse -> Settings -> Prinnter
  3. Choose edit profile
  4. Change setting in "Import printer" (change make and different model)
  5. Click save
  6. Settings are not beeing saved, browser console throws error:

You are probably better off reporting this properly to either of the plugin authors, so they can figure out what is wrong - they may not frequent this forum, and if they are like me, will forget posts here within about 5 mins.

Thank you Charlie.
But whom should I report it to? Octolapse/PreetyGcode?

Temporary solution is to just disable PreetyGcode plugin and it works fine.

I can't actually answer that one - it could be a conflicting dependency brought in by one of them.

Pinging @FormerLurker and @Kragrathea since they are maintainers. They're both good people and I'm sure (:wink:) they won't mind if you report the problem to one but it turns out to be the other.

1 Like

I installed OctoLapse 1.4.1 with latest PrettyGCode but I was unable to reproduce this. Maybe some other plugin is involved. Or maybe it is some sort of race condition.

Hey, not sure if you created an issue or not, I've been working all day every day for the past two weeks, but if you did I will get to it ASAP.

Not yet. I was waiting for one of you guys to check this issue and decide.
This topic was created because I found workaround and wanted to share with community.
Do you wish me to create an issue?

Yes please :slight_smile: