Octolapse - Position Error

Hello, I tried to print something in octoprint but I discovered some issues with the octolapse.
I want to to make a time lapse with the octolapse plugin, and I did all the things which related to it, I entered the data about printer about the slicer, etc. when I'm start the print I get this massage:

Octolapse - Position Error

Position - Coordinates (X:None,Y:None,Z:None,E:60.00000) are out of the printer area! Cannot resume position tracking until the axis is homed, or until absolute coordinates are received.

I searched on the web how to overcome this problem, and I have tried couple things, such as:
changing the printer profile in octolapse, adding g90 and M82 before the starting script, playing with the X/Y/Z Axis Mode with all the options and all the related things to it.
I really dont know why its not working. if someone could help it will be great.
I'm using simplify3d:
starting script:
G21 ; set units to Millimeters
G90 ; absolute positioning
M82 ; set extruder to absolute mode
G92 E0 ; zero the E-axis
G1 E60 F300 ; extrude 20mm of filament at 800mm/min
G28 X Y ; home X Y axes
G1 Y20 ; Y axel forword
G28 Z G ; home Z axel

layer changing:
G4 P1

ending script:
M104 S0 ; turn off extruder
M140 S0 ; turn off bed
G91 ; relative movements
G1 F150 ; slow Z rate
G1 Z15 ; Z up 15mm
M84 ; disable motors

I will be happpy if someone can help me with this. thanks!

1 Like