Octolapse problem with vase mode created in S3D


#1

when I print the 3Dbenchy all works fine, when I want to print a vase in vase mode my printer is getting nuts.
so I configured to move to the left to make a picture with octolapse, now what happens when you print the vase , is print the first layer and the printer head is moving to the left make picture and come to the middle and goes back without doing anything (or just place a dot of plastic) and goes back to the left and back to the middle, it's just like a tennis game, left middle left middle, ping pong
anybody who can help me out here?


#2

update: same issue with the SliCer software


#3

I'm sure the people who know Octolapse would like to know more about your setup.

  • Printer manufacturer and model
  • Single or dual extruder
  • OctoPrint and OctoPi versions
  • Hardware platform for OctoPrint (if Raspi, the model)
  • Specs for your Raspberry's DC adapter
  • Type of serial cable you're using
  • Screenshot of the Octolapse settings
  • Type of webcam

#4

@isacat,

This problem can (could? maybe it is fixed) also happen with the built in timelapse plugin when using vase mode. What is happening is you are using a layer change trigger in both cases. Since the 'vase mode' increases the z height with each motion, every movement is considered a new layer.

You have two options:

  1. Use a timer trigger (snapshot profiles) to take a snapshot after a period of time has elapsed. These can yield some interesting results, and the resulting timelapse pretty accurately reflects the current print time.
  2. Add a 'height' to the layer trigger. This will cause Octolapse to trigger an image every X mm. Just edit your snapshot profile and enter some non-zero value for 'Trigger Height' in millimeters, like 0.2. FYI, there are several default 'Height' triggers available depending on what version of Octolapse you are using if you don't want to bother changing your settings.

At some point I'll probably add a feature to detect and prevent vase mode issues like the one you experienced. If only there were more hours in the day!

Let me know if that helps!


#5

@FormerLurker, thanks for your information, it's now clear for me, I will test it and post my results here
thanks also for the great plugin, you did an amazing job on it and the community is loving it! it's changed the timelaps videos, now people are seeing how nice 3D printing is just by watching a youtube video made with timelapse.


#6

Thanks @isacat, I'm glad to help! You may want to check out the octolapse wiki which contains all sorts of hints, tricks and tutorials.

Also, perhaps you would like to test drive the latest development release candidate? I could use a few more testers, and there are some pretty cool new features inside. Check out this thread if you are interested, or shoot me a message.


#7

@FormerLurker I can print in vase mode now with the height 0.3mm and turned off zhop and retract, thanks :+1:
I want to test bud I am a newbie on octoprint/octolapse, I am not sure if I will be a great help?
still struggling with this error messages but it seems it's not preventing me to print ...

Octolapse - Position Error

Position - Coordinates (X:100.00000,Y:-3.00000,Z:0.30000,E:10.50000) are out of the printer area! Cannot resume position tracking until the axis is homed, or until absolute coordinates are received.


#8

Looks like you are using a genuine prusa, no? FYI, this issue has been fixed in the default profiles for newer versions of Octolapse.

Here's how to fix: Go into Octolapse tab and edit your printer profile. Click the check box next to 'Override Octoprint Printer Profile'. If you are using MK2/Mk2s use this
XMin: 0
XMax: 250
YMin: -3
YMax: 210
ZMin: 0
ZMax: 200

For the MK3 use this (I think...):
XMin: 0
XMax: 250
YMin: -3
YMax: 210
ZMin: 0
ZMax: 210

That should clear up your error!