OctoLapse won't take a snapshot with error

I have installed Octolapse and configured all setting in octolapse . When I start a print Octolapse indicates that it is running, but no snapshots are taken with Error shows

((( octolapse - camera error snapshot-thumbnail-create-error: create thumbnail - an unexpected exception occurred while creating a snapshot thumbnail. check the log file (plugin_octolapse.log) for details. - inner exception: 'module' object has no attribute 'open' )))

My printer is a JGAURORA A5 with MARLIN 1.1.9 on MKS GEN L board and MKS TFT screen that has been running very well on Octoprint with a Raspberry Pi4 model B. The video camera i am try is the
1-Raspberry Pi NoIR Camera .
2- Logitech webcam hd 720p .

both camera works and show a good picture in "CONTROL" tab . also test function are ok

i do a search online but couldn't find any solution
Can someone help me plz? I am getting crazy ?

you can see the logs from the link below


You've linked this to another thread on here which was solved. Did you take the same advice from over there which solved that one?

2020-02-28 13:01:57,924 Traceback (most recent call last):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_octolapse/__init__.py", line 1318, in on_gcode_queuing
    return self.Timelapse.on_gcode_queuing(cmd, cmd_type, gcode, kwargs["tags"])
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_octolapse/timelapse.py", line 568, in on_gcode_queuing
    if self._is_snapshot_command(self.Settings.current_printer(), command_string):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_octolapse/timelapse.py", line 1012, in _is_snapshot_command
    return command_string.lower() == printer.snapshot_command.lower()
AttributeError: 'NoneType' object has no attribute 'snapshot_command'