Octopi can't connect to printer

My octopi can't connect to my printer. Whenever I try to connect to the printer with baudrate on auto it comes up with the mesage: "Offline (Error: No more baudrates to test, and no suitable baudrate found.)". I cannot access octoprint.log, and I have to access octoprint via the ip address because octopi.local won't connect either. I just installed octopi on my raspberry pi and am running the latest version. I have never connected my 3d printer to octopi before and I have the Monoprice Select Mini v2. Does anyone have a fix for how I can connect to the printer?

One step at a time.

Can you connect to OctoPrint with your browser? If so, then using the "wrench" icon at the top open Settings and on the left side, click on Logging. On the right will be a list of log files with a "download" and a "delete" icon next to each. Click the "download" icon next to octoprint.log and you should now have a file you can look at or post here.

Can you connect to your Raspberry Pi with SSH? You didn't mention what type of system you are using to connect to OctoPrint (i.e. Windows, Linux, Mac) so we can't give further instructions.

What model Raspberry Pi do you have? What version of OctoPi did you install? How is the RPi connected to your network (i.e. wireless or wired)?

Remember that we can't read your mind. The more information (i.e. details) you give us, the better help we can provide. Too much is way better than too little.

Here is the error log file here: octoprint.log (134.6 KB)

I am using windows and I can connect to the pi using SSH. I have a Pi 2 B and it is connected with a wireless dongle (it's not one made for the raspberry pi, so I installed drivers made for raspbian onto it so that the pi can connect to the internet wirelessly). I'm not sure what version of octoprint I have, but I installed it yesterday, so I would assume it's the latest one.

Excellent. Now we need @foosel to look at the log file because it is beyond my knowledge.

I have a stupid question...

Are you plugging the USB cable from your printer into your computer, or to the Raspberry ?

Also, is the baud rate set in the printer configuration panel ?

You'll find that under Configuration/General/Baudrate Then click Back, then Store to EEPROM

I'm plugging the pi into the 3d printer into the pi, and it won't connect to the printer on auto or on 115200 (which is the baudrate that my pc connects to the printer with (I did also try other baudrates but none of them worked)).

Please enable serial.log creation:

Then try connecting to your printer. Then provide the resulting serial.log file (it's at the same place where you got your octoprint.log from).

Ah, only saw that just now... Install this plugin, that printer is known to otherwise cause issues while connecting.

It's btw also known to have thermal runaway protection disabled, so you might want to look into replaying its firmware.

Thanks, That fixed it!