Octopi has IP and MAC address but cant connect in browser

What is the problem?
Ive had octoprint running for a little over a year now with no problems, Ive always used the IP address in my browser to connect with no problems. But I got a new modem router and since then connecting to the new IP has been hit or miss. Some days it works, other days it doesnt. Sometimes if I restart the Pi it will work for a few hours then stop working. I can verify that the Pi is still connected to the network through my router but the browser returns " This site can’t be reached"
What did you already try to solve it?
checking the wifi name is correct, checking the password, restarting the modem
Logs (syslog, dmesg, ... no logs, no support)
im not sure how to get logs (tired downloading winscp and couldnt get it to connect)
Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
running windows, to Cox Panoramic Gateway, raspberry pi 4.0


you don't need ssh or winscp to get logs, OctoPrint has a handy function to collect them for you. Scroll down to the very end of the web interface, to the right, really tiny, is "System" Click!
Then you see a big friendly button "Download Systeminfo Bundle". Click!
It downloads to your download-directory and you can upload it to your post, easy and useful.

What happens when you try to access octopi.local in your browser?

Both octopi.local and the IP address are returning that they can’t be reached. But i have insured that the router is connected to my raspberry pi on that IP address.

is that IP on the same network as your other computers?

There is a FAQ entry that may give you inspirations wifi-setup-and-troubleshooting

1 Like

The IP address listed in my modem router settings is what i type into my browser. It’s on the same network all my devices are using that are online.

Good. When the router can see the printhost then things work as expected on that level.

You say the issues you're having are sometimes visible, sometimes not. So the task is to work out what is different in either case.

Yeah I’ve haven’t made any changes but now when I reset the Pi it isn’t connecting anymore which uses to fix the issue.

reset as in power cycle during operation? You should avoid doing that. Each time the power dies while the OS has files open and is busy writing to them random sh*t can happen to the file system. Sooner or later you'll add new problems to the one you already have.
From what you describe the pi seems to be the victim, not the culprit.

What you can try is: add a monitor and usb keyboard to your raspi, log in with pi/raspberry and check connectivity and settings from within.
sudo ifconfig -a would be about the first thing I tried. Come back here with what it showed you.
And while you're at it: do you see a yellow lightning-icon at the top of the screen? Insufficient power supply can be a reason for wifi problems. See the link above for a checklist to work down on.

i ordered an official pi power supply for my 4B and mico hdmi to hdmi cord so ill update when i get those next week .

I had similar problems when I forgot to change the country setting in wpa_supplicant.conf
Sometimes the PI worked just fine and sometimes it would connect to the router but was not reachable. I even experienced different PIs behaving differently with the wrong country setting.

I have your answer! Well maybe. I had the exact same issue when I first set up my Pi. If you have a dual-band router 2.4 and 5 GHz and you have them both setup on the same SSID, the Pi and or the wireless device you are connecting to will switch between the bands based on the single strength. Now people will tell you that the Pi and the device you are connecting to must be on the same band, that's not entirely true. If your router is set up incorrectly they will have to be on the same band. This is likely your case and why it's a random issue. When they aren't on the same band, you can't connect. To fix this, go into your router's wireless settings and look for something like "Set AP Isolated" and make sure it's set to No. When set to yes, it blocks traffic across the bands. When set No is allows cross-talk. I made that change in it's worked perfectly ever since.