Octopi not connect to wifi

Mi Octopi don't connect to the wifi, after the message "You may now open a web browser on your local network and navigate to any of the following addresses to access octoprint:"

don't appear any IP

with ifconfig's the raspberry show me the message: <UP,BROADCAST,MULTICAST>

So I undertand the raspberry don't connect to the wifi

What did you already try to solve it?

I flash with balenaEtcher
I try to reflash octopi
I try to change the network to connect (in no one net works)
I try to install raspbian and verify that works the Wifi of the Raspberry (and it works)
I change the region of the raspberry to my region
I put mi net into the WPA/WPA2 location (my net is WPA)
I read the WiFi setup and troubleshooting but can't solve it

Logs (octoprint.log, serial.log or output on terminal tab, ...)

I don't know how to get the logs

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, ...)

Is a RaspberryPi 3B+ with the 1.6.0 version of OctoPi

Just click onto the blue printed word logs...

if I follow the instruccions of the page Where can I find OctoPrint's and OctoPi's log files? tell me to use WinSCP, but WinSCP is for net, and i can't connect the raspberry to the net

If you have worked through the suggestions in Wifi setup and Troubleshooting:

The response you noted to the command ifconfig wlan0 does indicate that your Pi is not connected to your network.

What did you see when you typed in sudo iwlist wlan0 scan
This will tell you if your Pi can actually see that your wifi network exists (whether the pi is connected to it or not).

What program/App did you use to edit the file octopi-wpa-supplicant.txt ? Using an inappropriate App to modify the file can change it in ways that the Pi will not be able to use. (The Wifi troubleshooting and setup guide gives some suggestions on good apps to use. Windows Notepad/Wordpad do not work, nor does Apple's TextEdit, unless you modify its settings.)

When you entered your WiFi network name and password, did you also remember to delete the # from the four lines in that WPA section? There are examples of what that section should look like before and after you change it in the "WiFi setup and troubleshooting" guide.

It's missing the flag RUNNING so it's not been given an IP address by the DHCP server. This would match the original poster's description of not having an IP.

Note that the Raspberry Pi 3B+ has support for wifi 2.4Ghz and 5Ghz zones, for what it's worth. This could be causing some confusion.

Try putting the microSD back into your workstation and follow this section of some instructions I created.

1 Like

I'm using Notepad++, I'm on windows 10, with the command sudo iwlist wlan0 scan appear some information, about net signals, but I don't know how to move along the info

I have deleted the #

I follow the tutorial, but still not working for me :frowning: by the way, my router only give 2.4Ghz

I put my "octopi-wpa-supplicant.txt"

# Use this file to configure your wifi connection(s).
#
# Just uncomment the lines prefixed with a single # of the configuration
# that matches your wifi setup and fill in SSID and passphrase.
#
# You can configure multiple wifi connections by adding more 'network'
# blocks.
#
# See https://linux.die.net/man/5/wpa_supplicant.conf
# (or 'man -s 5 wpa_supplicant.conf') for advanced options going beyond
# the examples provided below (e.g. various WPA Enterprise setups).
#
# !!!!! HEADS-UP WINDOWS USERS !!!!!
#
# Do not use Wordpad for editing this file, it will mangle it and your
# configuration won't work. Use a proper text editor instead.
# Recommended: Notepad++, VSCode, Atom, SublimeText.
#
# !!!!! HEADS-UP MACOSX USERS !!!!!
#
# If you use Textedit to edit this file make sure to use "plain text format"
# and "disable smart quotes" in "Textedit > Preferences", otherwise Textedit
# will use none-compatible characters and your network configuration won't
# work!

## WPA/WPA2 secured
network={
  ssid="MOVISTAR_58AF"
  psk="My net password"
}

## Open/unsecured
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#}

## WEP "secured"
##
## WEP can be cracked within minutes. If your network is still relying on this
## encryption scheme you should seriously consider to update your network ASAP.
#network={
#  ssid="put SSID here"
#  key_mgmt=NONE
#  wep_key0="put password here"
#  wep_tx_keyidx=0
#}

# Uncomment the country your Pi is in to activate Wifi in RaspberryPi 3 B+ and above
# For full list see: https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2
#country=GB # United Kingdom
#country=CA # Canada
#country=DE # Germany
#country=FR # France
#country=US # United States
country=ES # Spain

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

I have managed to recover the logs. Here is it:

octoprint.log (87.0 KB)

the other logs, are empty

The most important thing is do you see your network listed in the results of that command?

I hate to ask the obvious, but are you certain dad you entered the SSID and password exactly as you should?

yes, y confirm twice the info of the SSID and password, and in the network list, appear un secon place my network

The fact that you can see your network listed in the output of the iwlist command means that your Pi can at least see the network. This is good news.

What are you using for a power supply? An poor power supply can cause all sorts of problems. Some of them may be only intermittent problems. Failure of the WiFi is one of the more common symptoms. I know you have tried connecting from an SD card with Raspian installed and it worked, so the power supply may be OK. I just mention it because a weak power supply is one of those things that might work some of the time or on some set-ups but not on others.

Try this version, having deleted everything else in that file including all the other sections and comments.

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=ES
 
network={
        ssid="MOVISTAR_58AF"
        psk="your_password_without_spaces"
        key_mgmt=WPA-PSK
}

1 Like

yes, the power supply is 5V 2,5A (I live is Spain)

nope, the same thing :pensive: don't give IP to my raspberry

I'm desperate :sob:

It's like the PI it's not reading the file of the wifi :man_shrugging: it can be?

A work around: run the script included with OctoPi to install the desktop. Then connect to the WiFi from the desktop (I'm guessing the desktop is the way you connected when you tried installing Raspian and were able to connect). Some others have had success with this when everything else failed.

Running the desktop does consume some resources on the Pi. If you are running a 3B+, that probably will not be an issue for you. Once you have successfully connected from the desktop, you can set the Pi to boot to the command line again. This would avoid the extra load of running the desktop, if you don't need it.

sorry for that, but how I run the desktop :S some tutorial?

I'm totally new in this world of the raspberry

I would have suggested to simply connect it via Ethernet cable in order to get to it.

Does raspi-config uninstall x11, etc? I would have to check that one.

I don't know. I was told that if you install the desktop, but set it to boot to the command line, you don't consume the extra resources. Whether that frees up 100% of the added load, or just some of it, I've never looked in to.

What I do in a case like this is...

which raspi-config
# and then...
nano pathToFile

I then go to school on what it does in whatever section that is. I'll boot up a Pi after drinking my coffee and sleuth this.