Octopi wifi will not work

What is the problem?

I am trying to get the latest version of octopi working using headless wifi setup.
Using the latest raspberry pi imager i selected octopi image to burn onto microsd.
I also selected control-shift-x to configgure wifi settings
When the pi booted up, i checked to see if the wifi had connected
using ifconfig but the wifi network does not shows up.

I have tried various options but the wifi never works.
I have configured the octopi-wpa-supplicant.txt manually as follows

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


Have you seen this when you opened this thread:

Logs (syslog, dmesg, ... no logs, no support )

Additional information about your network (Hardware you are trying to connect to , hardware you are trying to connect from , router, access point, used operating systems, ...)

Can you share the ifconfig result?

You might try working through WiFi setup and troubleshooting

Most of it was written before the Control-Shift-X method of setting up WiFi was implemented, but the common WiFi problems and troubleshooting methods are still the same.

Have you put your details in the SSID and password fields?, I think its better to have a SSID that is just 2.4G, not one that is shared between 2.4G and 5G.

After further checking: testing turns out the raspberry pi is fault, I will be returning it for a replacement
Thanks for your help, you can close this case