Octopi works fine, then wont boot up on next print

I have a Rpi 3B and have installed Octoprint several times. It all works well then next time I go to use it, the Pi won't boot. I have to re install the image onto the micro sd. I even tried restoring a backup, but that failed too.

So, here I am, up and working. What can I do to ensure this does not keep happening? It's version 0. 18.0


I have a Rpi 3B as well, running octopi 0.18.0 and I never had to reinstall the image. What you describe is not what generally people experience running OctoPrint on octopi.

It appears that something you do is very different from what most users do. And that results in a different experience.

But how can we know? You don't tell us much about your way of handling the pi, no logs, no steps to repro, not how you halt the system before turning off the power, not even a word on how you determine the pi didn't boot.

We can't read your mind (or your pi's syslog) so with the info you gave us, the answer to

clearly is: something different.

Obviously the wrong sub-forum.

@adweavers :
You may close this thread and open a new one in Get-Help with all the requested information.

Please tell me where I would find the syslog. On the SD card?

The logs are found within the octopi OS when it is running.

I don't know what you are doing to boot, but on my Pi 4B it requires that I have a monitor attached to boot, otherwise the boot just hangs when trying to start the graphics. I don't have a 3B so don't know if it is the same, but you should definitely give us more info as to how you actually get it to finish booting.

A reinstall of the OS is certainly not required for booting.

How do you shut it down when you are done printing?

From the Shutdown System command, next to the wrench symbol. To use the Pi again, I cycle the power plug and it starts flickering into life. However, often on doing this no green light, not even a flicker. It's as if there is no power. I tried putting the SD card into another pi and plugging it in, this time, a flicker of green light but no boot. Power supply checked, (it's original Rpi power plug) % volts fine.

I'm not sure how to view logs if the Pi won't boot? I re-flash the image onto the SD and it boots as normal. I generally leave the Pi powered on and it's not a problem. If I need to unplug it for any reason to move printer around, on re-powering the problem is usually there.

One person suggested he has to have a monitor connected for his Rpi to boot. This should run headless surely?

Thanks for the replies so far, even the sarcastic ones!

Yes, but not the WEB GUI: its the command line back end. You can see if the system boots up properly.

We still don't know what Pi you use, what OctoPi version and what OctoPrint version. And if you have some additional plugns installed.

My OP explains what Pi and version I use. I'll try adding a monitor and report my findings next time this happens.

Sorry, overseen it. Was quite embedded in the text.

It was in his initial post. I noticed because I have the same Pi. Mine works great. Both of them.

But, I do get an under-voltage report every time I restart either the OS or Octoprint.

In my case that's caused by hanging too many plugs off the same extension cord... I'm in an unfinished office without any outlets (yet).

I've used Linux for over 25 years as my primary OS for both desktops and laptops, at home and work.

syslog, and others, are in /var/log.

There will also be a log file called dmesg. That's also a command that can teach you other information.

Check for a boot log named boot.

Learn how to use ssh. If you're coming from a Windows PC, get putty and learn how to use it. If you're on a Mac, learn how to use the terminal and ssh from the CLI (command-line interface).

You can get a nice log reader called glogg. Figure out how it's used.

First, become super user (root), then run:

apt install glogg

Have fun, and remember, when you get to a point where you're stuck, Duck Duck Go is your friend.

Good luck!



Thanks for your detailed reply. I will have a look into your suggestions later.

Kind regards,


I can only guess it's a bad SD card. I've been running my octoprint installs on several pi machines for years and they work well. If it crashes after a reboot, well, probably bad media.


I've had the same issue with my Octopi had to re-install OS for it to work, turn out to be my SD card. Try a different SD card!