Octopod not installing

I am trying to install the OctoPod plugin but it sits at the installing screen - "Installing plugin "OctoPrint-OctoPod" from https://github.com/gdombiak/OctoPrint-OctoPod/archive/master.zip..." forever until cancelled.

I have tried to install it via the command line via an SSH session by using the command - sudo pip install "https://github.com/gdombiak/OctoPrint-OctoPod/archive/master.zip" but this fails with the following error:

Could not import OctoPrint's setuptools, are you sure you are running that under the same python installation that OctoPrint is installed under?

  • ----------------------------------------*
    Command "python setup.py egg_info" failed with error code 255 in /tmp/pip-req-build-lOlk8P/

Can anyone assist me to get this installed, I am running Octoprint version 1.5.2 OctoPi version 0.17.0


This probably means you have an undervoltage issue, please upload the octoprint.log. There is currently a bug where this issue is not reported to the plugin manager, that is fixed for the next release of OctoPrint.

This is not the Python installation that OctoPrint is running under, for two reasons. One, you have used sudo for some unknown reason - OctoPrint is not installed as root, it is installed as a regular user. Second, it is probably in a virtual environment not the global Python install.

So the correct command for an OctoPi image install would be:

~/oprint/bin/pip install "https://github.com/gdombiak/OctoPrint-OctoPod/archive/master.zip"

Though you really should fix the undervoltage issue, if that is in fact the issue.

Thanks Charlie,

I have attached a copy of my octoprint.log (10.2 KB) , I am not seeing any message about undervoltage being reported in the GUI for octoprint.

I have tried to install it via SSH logged in as the user pi but I get the same message

The throttle state is reported as 0x50005, which means the Pi is actively throttling due to undervoltage. I'm not sure why there isn't a massive warning there in the log but this means you need a better power supply. The system is unstable and installing plugins could cause significant issues.

1 Like

Well that would explain it then - I am using a Raspberry Pi 3 Model B to run it on and thought my power supply was man enough.

Struggling to find the requirements for a power supply online.

5.1V, 2.5A for the Pi 3B. You can find all the power requirements here:

Thanks - I wonder if my USB webcam is drawing too much power. Will try to unplug it a see if I can install the plug-in