Octoprint and Sony Alpha 5100 DSLR - finally working

Hi all,
I just wanted to share my experience of getting my Sony Alpha 5100 working with Octoprint.
My Setup.

Ender 3 Printer -

  • Firmware 2.0.6.X
  • Stock extruder
  • Buildplate - Creality Glass
  • SKR mini V3 v2
  • TFT35 V3 LCD

Raspbery Pi - 4GB Ram

  • 16GB Microsd card
  • Octoprint 1.9.3 - New Camera Stack
  • Video capture card

DSLR Camera Sony Alpha 5100

  • 16GB memory card
  • Dummy Battery
  • attached to video capture - Raspberry Pi 4
  • USB micro cable attached to Raspberry Pi 4

As I am new to 3D printing to say I had clue would be an under statement. My mission to get my Sony Alpha 5100 working with Octoprint and stream a successful video. I tried Docker in Linux using virtualization part successful, but could not get stream working correctly. Tested on Windows 10 worked ok with Yawcam.

However, I did not want my PC tethered to the 3D printer. I got a Raspberry Pi 4 installed the new camera stack. Once the camera fired up I had a visual image which I was not expecting.

I watched this video (This worked for me the best) to setup the Sony Alpha.

Now I could see my stream, I was really pleased. Installed gphoto2 followed the guide from Octoprint website and did the necessary configurations. I had video capture card plugged into the Raspbery Pi 4. So I tried running gphoto2 -auto-detect, but I was getting failures my heart sank.

I took a step back and said wait the commands only work with USB cable not a video capture card which is for streaming and video capture. I inserted a USB micro into my Sony and the other end to the raspberry Pi, at this stage I was thinking this would not work.

I ran the command via putty on the raspberry Pi gphot2 -auto-detect, success could not believe it. I ran gphoto2 --trigger-capture-and-download success again. I couldn't remember all a the gphoto2 commands so I used this video where there is a pastebin of command for gphoto2.

I have achieved video streaming and running gphoto2 commands which is feat in itself so.

I need to make sure I could send files from Cura slicer to Octoprint. So I downloaded a file from Thingiverse loaded it into Cura slicer, I got a error message "Octolapse startup failed, slicer settings missing" Another hurdle to jump over.

A quick search on YouTube I found this video which solved my issues. Fomerlurker had posted some scripts from a another developer which helped resolve my problems. Once the code was inserted into the start of Gcode, the file was passed from Cura to the printer and printing started, boy was I over joyed.

After a month of intense researching frustration and self determination I finally got the Sony Alpha 5100 working. I had to invest in a Raspberry Pi 4 which helped me resolve many issues. Now I can take time-lapse recordings with my Sony Dslr camera without having to invest in a webcam. I use the camera conference calls for work, so it made sense to use it for 3D printing.

I'm not a expert in 3D printing but if you are using a Sony Alpha 5100, hope this will give you some mileage in resolving some of the issues I overcame.

Research sites used to resolve the issues.

Support for using octolapse with dslr
https://www.youtube.com/watch?v=bmCzwhHcQhU (This worked for me with Sony Dslr)

Using gphoto2 application

Slicing with Cura - Octolapse startup failed slicer settings missing

1 Like