Octoprint changes Z-offset when my prints begin

Equipment: Creality Ender 3 Pro
Raspberry Pi 3 b+
Octoprint Version: 1.4.2,
NO Gcode scripts running

Just added octopi to my ender 3 for the first time via Rasp Pi 3 b+ and Pi cam V2. All hardware and software runs/loads without issue.

PROBLEM: If I load a gcode file through octoprint everything starts fine...printer head / bed heat up normally, but once the actual print starts, the print head will move approximately 10mm above the print surface and will then attempt to print. If I do NOT initially use octoprint but rather use the sd card slot of the ender 3, this problem does not exist.

However, If I first print from ocotoprint and the issue occurs, the same problem will occur if I attempt to print on the ender 3 from sd card, unless I first auto home and then save the offsets and then start my print job again. Meaning, as long as I do not attempt to print from ocotprint first, the ender 3 prints just fine if I print directly from its own SD card and I do not use octoprint first.

To attempt to solve, I have checked to ensure my printer profile in octoprint is correct and bed size settings are correct. I have tried different gcode files and the same problem occurs. This issue does NOT occur if I print directly from Ender 3 SD card without using octoprint first.

What is the problem?

Z-offest is being altered at start of print

What did you already try to solve it?

Checked settings

Have you tried running in safe mode and if so did it solve the issue?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

I don't yet know how to add those.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.4.2octoprint.log.zip (4.5 KB)

Hello @greko96!

If you attempt to solve you shouldn't have deleted the template that occurred when you opened this thread. So value informations are missing: The Logs and the query to test in safe mode

1 Like