OctoPrint do not start anymore

I am using octoprint since month now without any issues.
After a Firmware update on the printer, the printer setting RPI port ON changed to OFF (without my recognition) and octoprint was not able to connect anymore (obviously).
Unfortunately I searched on wrong places and after changes I made in several files I rebooted the system multiple times... once after each change. After the last reboot octoprint seems not to load anymore... Revert all changes but no success to load octoprint.
Interestingwise there is NO log entry anymore in octoprint.log since the last regular shutdown of the last reboot.

What is the problem?
Octoprint do not start anymore. No entries in octoprint.log since shutdown

What did you already try to solve it?
Revert all changes, multiple restarts, multiple manual octoprint start tries (sudo service octoprint restart/start), tried adding start in safe mode in config.yaml

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)

2019-09-12 14:11:32,715 - octoprint.server.preemptive_cache - INFO - ... done in 17.76s

2019-09-12 14:11:35,658 - octoprint.plugins.pluginmanager - INFO - Loaded plugin repository data from https://plugins.octoprint.org/plugins.json

2019-09-12 14:11:36,093 - octoprint.plugins.pluginmanager - INFO - Loaded notice data from disk, was still valid

2019-09-12 14:12:43,809 - octoprint.server.util.sockjs - INFO - Client connection closed: ::ffff:

2019-09-12 14:12:43,974 - octoprint.server - INFO - Shutting down...

2019-09-12 14:12:44,268 - octoprint.events - INFO - Processing shutdown event, this will be our last event

2019-09-12 14:12:44,274 - octoprint.events - INFO - Event loop shut down

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)

OctoPrint version: 1.3.11
OctoPi version: 0.16.0
Rasberry Pi 3+B

When you try to go to the web interface, you should be greeted with a "OctoPrint is not running page" that outlines some things to try. Please try them and report back on the results.

Hi Gina (nice to hear from neighbourhood :grinning:),

already done... sorry not mentioned it in total. Here the result missing out of step 1:

pi@octopi : ~/.octoprint ** ps -ef | grep -i octoprint | grep -i python **pi@octopi** : **~/.octoprint

Step 2: as mentioned in my post: No log entry in octoprint.log anymore at all.
Step 3: tried to restart/start without any success (and without any additional log entry).

The only additional information coming into top of my head from yesterday:
if I open the web links to the webcam and webcam2... this is working. But I honestly do not know if this is issue related.
Thanks so far!
If we get this sorted I owe you more than a coffee!

Hm, I thought those steps also involved starting it manually from CLI, but I might be misremembering.

Try this please:

  • SSH into the machine
  • Shutdown the OctoPrint service (it's not running, but just in case...): sudo service octoprint stop
  • Activate the virtual environment: source ~/oprint/bin/activate
  • Start OctoPrint manually on the console: octoprint serve --debug --host

That should hopefully print some error or at least something we can work with.

PS: Also - neighborhood? Are you from the Rhein Main Area? :smiley:

Gina! You are my hero!!

the errors produced stated:

2019-09-13 10:57:26,619 - octoprint.startup - CRITICAL - There was a fatal error starting up OctoPrint.

Could not initialize settings manager: Error parsing the configuration file, it appears to be invalid YAML. The parser reported an error on line 42, column 1.

There was a fatal error starting up OctoPrint.

I am not able to find the error in the config.yaml but I replaced the config.yaml with a former working one out of my backup... and... it worked!!!

Thank you so much!!
Feel invited for a coffee, cake, lunch... what ever!

P.S. jepp nearby your city. Born 15km living 30km.