Octoprint is sending m112 to my prusa mk3s+ with MMU2 after recent prusa firmware update

Please share another system info bundle. Did you also restart OctoPrint and reconnect? Never mind, you said you rebooted

I connected again and this time it will print.

Recv: T:254.90 E:0 B:109.9
Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
Send: N62 M105*19
Recv: LCD status changed
Recv: ok
Send: N63 M109 S255*95
Recv: Full RX Buffer
Recv: ok
Recv: ok T:255.2 /255.0 B:110.0 /110.0 T0:255.2 /255.0 @:39 B@:81 P:0.0 A:35.3
Send: N64 G28 W*86
Recv: Error:Line Number is not Last Line Number+1, Last Line: 18
Recv: Resend: 19
Recv: ok
Send: N19 M105*31
Recv: Error:Line Number is not Last Line Number+1, Last Line: 18
Recv: Resend: 19
Recv: ok
Recv: ok T:255.2 /255.0 B:110.0 /110.0 T0:255.2 /255.0 @:39 B@:81 P:0.0 A:35.3
Send: N20 M105*21
Recv: ok T:255.2 /255.0 B:110.0 /110.0 T0:255.2 /255.0 @:39 B@:81 P:0.0 A:35.3
[octoprint-systeminfo-20220308145050.zip|attachment](upload://mhDy6dkWZTpaItnLxglp2l8IZHM.zip) (67.0 KB)

Still complains about a full rx buffer however, so something still is not right. Please share another system info bundle. The truncated serial.log sadly tells me nothing as everything relevant happens before your excerpt there.

Also see

octoprint-systeminfo-20220308145050.zip (67.0 KB)
sorry I attached it in the text block

It's still sending Tx without line number and check sum, same for Tc. So something about the changes didn't take at all.

I logged on with ssh and edited the file as your post says and saved before rebooting.

it didn't remember the changes so I have tried again, saved the file and loaded it back in to be sure.

You've set serial.timeout.sendChecksumWithUnknownCommands and serial.timeout.unknownCommandsNeedAck to true. That's not what was posted in the linked comment or how it looked in the example :wink:

Try this instead, via SSH as well:

~/oprint/bin/octoprint config set --bool serial.sendChecksumWithUnknownCommands true
~/oprint/bin/octoprint config set --bool serial.unknownCommandsNeedAck true

Should hopefully be less error prone.

Oh I put them in timeout: my mistake

HI, are these commands reset after a reboot and this is the correct command to view it
sudo nano ~/.octoprint/config.yaml

I am not seeing them after the a reboot and it didn't help. I know how to get around the problem, just pre heat the bed and nozzle first then I am not seeing any errors.

and I am seeing this problem more today because I am printing in asa and it takes a long time to warm up.

Try the config statements I told you to use and for the love of all that is holy don't use sudo for editing a user readable config file. sudo usually isn't needed and just blindly slapping it in front of commands can break stuff.

And yes, this should persist a reboot.

sorry I don't know much about these operating systems so it's not always easy for me to understand what I should be doing.
I did enter them as you requested and removed my mistakes, but it made no change. I had to carry on printing so have not had chance to try anything again.

If it keeps reverting after a reboot then something might also be up with your file system. That's out of OctoPrint's control though. In general I was told by Prusa that these settings should be fixing the issue, which is rooted in the firmware not being able to handle getting Tx or Tc pushed "out of order" so to speak. OctoPrint has always been doing this unless the above settings were set to true, but something in the latest firmware caused this to now lead to a cascade of errors in communication which in the end results in an M112 and disconnect.

If you can't get the settings to work, I suggest to roll back the firmware update for now and then wait for OctoPrint 1.8.0.

This is after the config statements

and after a reboot they are missing so I will look into this problem.

What are you doing to close and save the file? What key combinations?

ctrl O to write and ctrl X to exit. if I load the file back in the values are in the saved file.

Just thought I would add that since I started pre heating I am not having the problem so I will continue to do this. I have not had time to look at why it will not remember those changes and think I will just make a new sd install and try that.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.