Octoprint on a pi4 8gb

What is the problem?
I have tried to get the latest download from Octoprint, But When i run it on the PI4 it say that this is not the right version.

If i try to install it under the running software on the pi4
Nothing happens

What did you already try to solve it?
Brand new user

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

Latest version of the raspberry pi4 8Gb

Simply need a guide to install the octoprint on the 8gb version

1 Like

1 Like

Still no luck

"Still no luck" does not help us diagnose your problem. What is happening? What is working, what is not? If you get an error message, don't say "I got an error", but say what error message you get (as exact as possible). It might not mean much to you, but it might mean the difference between us not knowing what is going on either or us being able to help you work around the issue you are having.

1 Like

I try to descripe it in detail later today

When i use the Octopi solution, i get the following message when i start the pi
This board require newer software

When i try to install the Octoprint on the supplyed card that runs on the raspberry, the Octoprint installs correct, but when i thry to run

pi@raspberrypi ~ $ ~/OctoPrint/venv/bin/octoprint serve

the program run in the terminal with test at the nothing happens when the test stop i simply stay with that picture

and if i try octoprint.local it directs me to a google page.
the Ip add does not work either

Is it because the 8gb runs 64bit

1 Like

Very likely.

Someone needs to 1) donate an 8GB RPi4 to @guysoft so he can develop a compatible OctoPi and 2) donate an 8GB RPi4 to @foosel so she can develop a compatible OctoPrint.

If someone wanted this donation to be a single, floating, 8GB RPi4, then it should probably go to Gina first because OctoPi bundles a version of OctoPrint.

I wonder if the 64-bit Raspbian distribution runs on other RPi models?

1 Like

To answer my own question, Note, the 64bit OS is only install-able on the Pi 3 and Pi 4 devices.

I'm running Octopi on a Pi4. I don't recall any problems setting it up, at least none that relate to Octoprint (feel free to look at my other posts).
Have you run sudo apt update and sudo apt upgrade?

The RPi 4B comes in 4 flavors, 1GB, 2GB, 4GB, and 8GB. 4GB is the maximum amount of memory addressable with 32 bits of address so the first 3 models are supported by a 32 bit version of Raspbian. To address 8GB of memory, you need 64 bit addresses, i.e. a 64 bit version of Raspbian.

So, @Hairyloon, you have one of the three original RPi 4B models.

1 Like

Ah ok.
That makes sense.

What do you expect to happen? If you expect a UI to show on a screen connected to the raspberry pi, then your expectations are wrong. By default, OctoPrint is a "headless" server; no interface is shown on the Pi running OctoPrint. If you copy/paste the last couple of lines of the output when running that command, then - again - we might be able to tell you if OctoPrint is running as it should be, or not.

There can be many different reasons why name resolution does not work, but none of them have anything to do with OctoPrint running or not.

Here you go again with the "does not work". Details, or we cannot help you. What IP address do you use, and how did you get it? What do you get instead of the OctoPrint web page? Can you ping the ip address?

1 Like

I think @PrintedWeezl has created a 64bit raspbian image for OctoPrint recently...

Yep
I have to add the proxy and webcam script and then I'll upload it for everyone who wants to test it

3 Likes

Hello,

I just received my raspberry Pi 4 8GB and surprise, it does not work.
I have just found your discussion on the subject and I am very interested in the 64 bit version.
I am French and my English is not at the top but being a computer scientist I can do tests and give you my results.
Good development.

2 Likes

Thank you :slight_smile:
The image is in "pretesting" right now. Just finished it and sent it to @jneilliii and @foosel

It Sounds great with the script for the 8gb version.

Where are this going to be uploaded.

Impatient much @Stilfotografen? He's trying to nail down a couple of things that came out during my testing.

1 Like

If nothing unforseen happens I will release it on monday.

1 Like