🇺🇦 We stand with Ukraine! 🇺🇦

Octoprint on a pi4 8gb

Of course it will be code optimisations that either cant or won’t be back ported to 32 bit version that make the difference.

Hi Everyone, 1st time poster and first time user of a RPi 4! After reading your posts on here have managed to successfully get my Black Widow printing via Prusaslicer and Octoprint. Love the flexibility of not being next the printer all the time!
Am hoping someone with a lot more skills than me are working on getting the pi camera working so I can watch too. WIll be very excited to get that fix.

How are you guys getting the pi camera to work on this? I can't get mjpg-streamer to compile the input_raspicam.so module (using the manual install).

It seems to compile fine without errors but is skipping that file and probably others.

Hello,
i am new to the topic of raspberry pi, octoprint and 3d printing.
mistakenly i bought the Rapberry Pi with 8gb.
Now i try to get Octoprint working. unfortunately without success. I downloaded the beta-image and put it on the SD card using the Raspberry Pi Imager.
But how do I continue? I have neither keyboard nor monitor on my Raspberry at the moment.
It would be great if you could help me.

The download page for the official image got a quick start guide :slight_smile:

hello, I have read the quick start guide.
but where do I set the network data (ssid and password).
the file from the quickstart does not exist in the 64 bit version.

Are you sure you downloaded the octopi image?

OctoPI64-0.18.0-beta.zip

Technically, you could run the 64-bit version of Ubuntu, for what it's worth.


To the best of my knowledge, the 32-bit version of Raspbian has a single-process limitation of 4GB. As long as the kernel can address all of it then your own 32-bit compiled program should be reasonably happy. The recently-available Raspberry Pi OS on their website. I'm guessing that they've updated the kernel so that in 32-bit mode it can recognize all 8GB (probably like they did originally with the earlier IBM PC compatible computers).

Oh... and just a reminder that the 4B running in 64-bit mode can use the ARMv8 architecture, say, if you're installing NodeJS or you're trying to compile something.

Hello,
I actually brought in a false image. With the right one, it works right away.

1 Like

Hey All, i see the beta version available, is the dropbox link still the latest? I went to the main download page but I cant find any beta section so I'm thinking it is?

It's an unofficial beta (not by the people that make the official images but made with the same tools).
That's why it's just listed here.

And yeah that's the latest version of this beta.

I'll build a new one when a newer raspios image is released.

https://downloads.raspberrypi.org/raspios_arm64/images/

I'm having trouble getting Octopi working on my Pi 4B 8GB. I tried the 64bit Octopi build from @PrintedWeezl, and that seems to work, but I can't get my 4inch touch display to show anything. Right now, I have the 64bit Pi OS beta installed and managed to stumble my way through getting Octoprint up and running. Problem is that I can't for the life of me figure out how to get the pi camera running. The camera worked on PrintedWeezl's build, but again no display (although I was able to SSH in to do basic stuff... VNC however would not display a desktop). I'm very new to linux and 3D printing. Can someone walk me through this as if I was a grandma? XD

The camera worked for you?
It didn't for me when I made the image (well at least not on the pi 4) :smiley:
Have to test it with the latest updates again :slight_smile:

I'm not sure if I can help you with the display. Which one is it?

1 Like

It’s the Miuzei 4” touch screen. Works on the raspios I currently have installed, but I just can’t figure out this damn camera :sweat:

Which raspios are you using? 32 or 64bit?
Did you try it with this guide Setting up OctoPrint on a Raspberry Pi running Raspbian (for the cam)?
Maybe you have to assign more gpu memory because you got a display and a cam.
I would just try something like 512 mb. If that works you can lower it back to something that still works.

When using my image you should get an hdmi output. Strange.
Try hdmi_force_hotplug=1 maybe the pi doesn't detect the hdmi connection

I think I tried that command. Right now I’m running 64 bit. That guide is what got me to where I am. Octoprint boots at startup, monitor is working and I can log in from my network and use VNC. Just that webcam giving me issues (also haven’t tested it on my printer yet, hoping that won’t be a whole other issue)

working just fine, thanks

1 Like

hi , is there any new information of the HQ cam on Raspi 4b 8gb ? My cam is not working.

Actually yes :slight_smile:

Log in via ssh, run sudo apt update && sudo apt -y upgrade && sudo reboot and test again.
Seems like they fixed the problem.

I'll build a new image soon

1 Like