Octoprint & Printoid

About 2 weeks ago, I installed Printoid Premium on my phone (the paid version). The only time I have been able to connect to the printer/Pi/ whatever it connects to, was during the initial installation. Since then, it just keeps telling me "Unable to Connect"...even at home, on my wifi. I know Octoprint is connected to the network (wireless) because I can pull it up on my laptop, but it's no go on my phone. I've tried several of the published "troubleshoot" ideas, but none have worked. Any ideas ???? FWIW..I have a Galaxy Note 8.


That's not a OctoPrint plugin - so wrong section.
I moved your post to #general

Of course you can ask here for ideas but I would suggest you check out the printoid website or message the developer.

Simple question, but often overlooked:

Have you disabled mobile data and enabled WiFi? (Unless you've forwarded port 8080 [or 22 for SSH] to the Pi, you can only connect to it if what's trying to connect to it [your Note 8 in this case] is connected to your LAN.)

I've used Printoid Lite and Printoid Pro (installed back when it was available) successfully on Samsung Tablets and my Samsung Galaxy S9 phone.

If the Printoid application doesn't give you enough information in its error messages (or logs?), then you may have to capture the communications between the application and the RPi using tcpdump or something similar.

Printoid does have a website and the developer does respond to email. I believe that will be your best source for getting to the root of this issue.

Thanks. I've been in email contact with the developer, but he takes a LONG time to reply. Still waiting on a response for some of my questions. I might just eat the $8 and not screw with it. I don't need to control my printer via my phone. I only need to view the print, and I can successfully do that with "The Spaghetti Detective". I was just hoping to get someting I paid for to actually work. Oh well.