Octoprint server is currently not running(dir/network issue)

What is the problem?

Got Octoprint to finally work with the WIFI but now it doesnt seem to have a folder
octoprint.service: Failed at step EXEC spawning /home/pi/oprint/bin/octoprint: No such file or direct

What did you already try to solve it?

Tried to find the folder

  1. pi@octopi:~ $ ls -a
    . .. .bash_logout .bashrc .cache .gnupg .local .octoprint .profile OctoPrint mjpg-
  2. looked into logs
    but can't figure out what it could be apart from the dir issue:
    it could also be a installation issue because lacking network
    note: that I can use SSH and the network is connected to the internet(not sure if this matters)
  3. tried safe mode
    pi@octopi:~ $ nano .octoprint/config.yaml
    changed this:

startOnceInSafeMode: true
serverRestartCommand: sudo service octoprint restart
systemRestartCommand: sudo shutdown -r now
systemShutdownCommand: sudo shutdown -h now

Systeminfo Bundle

I can't access system info bundle cause I can't even open this

Additional information about your setup

OctoPrint unknown(according to CLI), OctoPi version: 0.18, ender6, firmware, chrome, operating system(windows10)
installed using rasberrypi imager

Please Advice
octoprint.log (151.5 KB)

Solution was to reinstall a new image using the imager

1 Like

Hello @david_t

Could you post this in a new post and do this: