OctoPrint wont install or update any plugins - exit code 1

I keep getting these same errors whenever I try and install a new plugin or update an existing one. At first I thought this error was just one specific plugin and I was going post it to their github tracker but then noticed it was impacting all plugins.

OctoPrint version : 1.7.2
OctoPi version : 0.18.0

I have tried rebooting multiple times, I tried reinstalling the initial plugin that was having the update issue but then learned that I couldn't install either (Same error).

I SSH'd into my OctoPi and did sudo apt-get update and sudo apt-get upgrade -y to try and fix this but issue persisted.

Here are my logs. Before uploading, I deleted the logs, restarted the server
,attempted to install a couple plugins, and restarted again.

octoprint.log (2.6 MB)
plugin_pluginmanager_console.log (11.3 KB)

Looks to me like your SD card is full. Seems to fail right at the unpacking stage. Ssh in and do a df -h and see what the root filesystem says

Says I am using 2.1GB of the available 29GB, so unfortunately that isn't the issue.
image