Octorelay is not installed

Hi. I've reinstalled my Octopi recently and while restoring from backup Octorelay's not been installed.
I've tried to manually install using the plugin manager and I got this output:

Requirement already satisfied: mdurl~=0.1 in /home/orangepi/OctoPrint/lib/python3.9/site-packages (from markdown-it-py>=2.2.0->rich<14,>=12->Flask-Limiter<4,>=3.3.0->OctoPrint->OctoRelay==3.14.0) (0.1.2)
Building wheels for collected packages: OctoRelay
Building wheel for OctoRelay (setup.py): started
Building wheel for OctoRelay (setup.py): finished with status 'done'
Created wheel for OctoRelay: filename=OctoRelay-3.14.0-py2.py3-none-any.whl size=37847 sha256=172e6f1f65e7d43ea713c388eae5c432abbba60552ace078be57bb4ba4de4ba9
Stored in directory: /tmp/pip-ephem-wheel-cache-qpsexni8/wheels/39/7d/9a/8490237f19a34f82393ee4ce71c15b27e9782809c1d5d3376e
Successfully built OctoRelay
Installing collected packages: OctoRelay
Attempting uninstall: OctoRelay
Found existing installation: OctoRelay 3.14.0
Uninstalling OctoRelay-3.14.0:
Successfully uninstalled OctoRelay-3.14.0
Successfully installed OctoRelay-3.14.0
After restarting Octorelay is not installed. I'm not sure whether it's an octoprint problem or something on github.
I'm using octopi 1.0.0 and OctoPrint 1.9.3.

Please upload the systeminfo bundle zip :slight_smile:

1 Like

Oh yeah, sorry
octoprint-systeminfo-20231109020051.zip (20.1 KB)

OctoRelay most likely only supports Raspberry Pis, which is why it will not load on an Orange Pi.

This is the same for gpiocontrol, enclosure, and octolight plugins that it looks like you also have installed.

1 Like

You may go with:


I just tried it and it downloaded fine, but the plugin is greyed out in manager with pending restart after a restart and a reboot. Does that mean it's incompatible or can it be fixed?

Also thanks for the recommendation.

You need to restart octoprint and then configure the plugin.

Note that, you need to have a micro controller like an esp32 to make use of the SIOControl plugIn. It connects to the ESP32 over serial for controlling its IO.

There are a lot of inexpensive boards you can get with an esp32 and relays to make good use of the SIOControl plugIn. I offer some but you can use just about any if you can hack the firmware a bit.

BTW.. I am the Author of the SIOControl PlugIn