Octprint RGB Status Plugin Problem HEEELLLP!

Hi,
I have had OctoPrint installed and running perfectly with my Ender 3 v2 for about two months. I was thinking of installing some LED's so I installed the OctoPrint-Rgb_status plugin through the plugin manger, after reboot, the OctoPrint-Rgb_status setup won't allow me past the setup "Raspberry Pi SPI Setup" screen.

I have tried entering the correct password so that the pi user can be added to the gpio group, when I click the Add to gpio Group button nothing happens, If I click the Finish button nothing happens!!

I am stuck at the screen, I need help to uninstall the plugin, restore to a previous backup, or something!!
I can still access the pi through SSH, but my command line experience is pretty limited.

I really need help here...

Simon

Python 3? It doesn't work. Install mine instead - WS281x LED Status.

If you are on OctoPrint 1.5.0, you can use the recovery page to uninstall - if not I'll try and find the correct command to uninstall it.

1 Like

Hey Charlie,
I cannot get to anything past this page, I am on python 3.
The whole problem I am having is I cannot get to anything the other side of this screen!
I would love to try your plugin, just need to get to a point where I can blitz this one, and install something else! :grinning:

I believe I am on the latest OctoPrint version that was released upto last week. I don't play around with beta and rc's :slight_smile:

There was a release this afternoon, that's why I asked :slightly_smiling_face:

Try this from SSH:
~/oprint/bin/pip uninstall octoprint_rgb_status, or maybe just rgb_status, unsure.
then sudo service octoprint restart

You'll enjoy my plugin, it has a lot of things...

2 Likes

You are awesome, that worked!! Thank you sooo much for your time!!

Question about your plugin, I have regular RGBW LEDs, will it work with those, or will I need the pixel individually addressable type?

Simon

No, you need the individually addressable type.

you saved my life......
~/oprint/bin/pip uninstall rgb_status
does the job
thank you

2 Likes

Little extreme, but I'll add it to the list of my achievements.

1 Like

OMG, thankyou. Was worried I'd have to reformat the Pi for a while there. Friggin RGB Status setup screens did the same thing to me. User 'pi' was already added to the gpio group (verified through SSH) but the moronic setup screen didn't think it had occurred and locked me out - unbelievable.

1 Like

Yeah, and the author still hasn't responded to the issue... or anything in the last 4 months.

If you do use my plugin, I'm around here far too much so no need to worry about that if you run into problems :upside_down_face: