Pause at layer end

Cool. You speak GCODE.

Do ya also speak Klingon ?

And how did you get G1 Z6.770 = .04 above start ?

Is the .04 in MM ?

Was that a calculation of stepper motor action ?

I do have the newest Cura, but, first of all, there are so many settings that it's just plain confusing, and I like the settings that I've currently got in my 15.04.6, and secondly, and probably most importantly, Octoprint allows you to import settings from Cura to use in its own slicer, which I find quite handy at times, BUT, only if you don't go any higher than version 15.04.6

Cura did a major overhaul after that, and the built in slicer gets as confused as I do by those settings

It's for those two reasons that I'm sticking with the older version

OK, call me a nerd :nerd_face: but I downloaded Cura 15.04.6 and have the following observations:

  1. You can have more than one "Pause at height", just click the plugin for as many as you want.
  2. "Pause at height" is brain-dead and gets confused with Z changes in the start gcode

Attached is an updated "Pause at height" that fixes that. Due to discourse not liking .py or .zip, I added a .log to the file name. You will have to remove that after you download it. Open Cura, go to the Plugins tab and at the bottom, click on "Open plugin location". Rename the old one (, put my modified, renamed version in that directory (you will need administrator privileges to do that). Close and open Cura and you should be good to go. (3.7 KB)

I inserted the "Pause at height" plugin twice, but I found only one pause in my gcode file. You can insert the plugin more than once, but it is only working one time.

Did you change the height of the second instance of the plugin? Here's what I did:

  1. Install Cura 15.04.6
  2. Start Cura, define a printer
  3. Load a file to slice, 3DBenchy.stl
  4. Click on the plugins tab
  5. Click on Pause at height 3 times
  6. Change the height of the second instance to 10
  7. Change the height of the third instance to 15
  8. Save the GCode
  9. Look at the GCode and discover that Z heights of 5,10, and 15 all occur in the start gcode.
  10. Go back to Cura, change the heights to 20, 30, 40.
  11. Save the GCode
  12. Look at the Gcode and see custom commands at Z=20, 30, and 40.
  13. Modify the to fix the start gcode problem.
  14. Open Cura again, change the heights to 5,10,15.
  15. Save the GCode
  16. Verify that my fix worked and there are 3 custom command sections at Z=5, 10, and 15.

That little magic trick was called subtraction. ha

G1 Z6.770                                  # Move to .04 above start
G0 F9000 X102.995 Y119.758 Z6.730          # Get ready to begin again

It's just the 6.770mm - 6.730mm = 0.04mm.

Actually... not seeing more than one

If I raise the height in MM, the custom moves up in layer height, but, I still see only one custom

I probably did something wrong (I did mention that I have no idea what I'm doing, didn't I ?)

Okay, I understand the Z6 now

I see the pause, the park, and the resume with your Z6 change explanation, but, why does the X resume in a different spot ?

I made an assumption that there was a G1 command right before your initial comment in which that was the final resting place before layer 85 starts.

@spyder Please open Cura and do steps 3-5 in my list and then take a screenshot and post it here.

Okay, but, I wanna try a quote first...

(So that's how you work the quote button...)

Yup, there's your code, 3 times. Then I changed them to 5, 10, and 15

I saved the gcode, then I opened it with notepad++ (like only insane people would do, cuz, really, who would be nutz enough to try to actually READ gcode while being a beginner ?)

What this looks like to me, (and I could be wrong here) is that 3 instances of the code tried to get inserted into Cura, but, only the last one had any effect

I'll eventually add a --codeAtZ flag to my GcodeEdit project... I just need to know what a good/solid pause looks like.

In theory, you could just run the GcodeEdit command as many times as you needed to.

only the last one had any effect

Only the first one had any effect (the Z values around ;LAYER:16 are around 5).

Looks like you did everything correctly.

Change the heights to 30, 40, 50 and see what you get. If you only get one CUSTOM section, then I'm confused because we are both running the same version of Cura (15.04.6) and I get 3 CUSTOM sections.

who would be nutz enough to try to actually READ gcode while being a beginner

Learning to read gcode is almost mandatory... Its part of your education! :rofl:

Yup, yer right, it's the first one

But still only the one tho

Well I'll be damned. Looks like I've been Peter Principled.

This is perfect!
I'm having a bit of a struggle with the plugin tho, when installed, settings-window cant be opened. I'm guessing its because it hasn't been updated.

If you have the time and energy, could you take a look?

Thanks in advance, take care

ps. Sorry for resurrecting a years old thread

Hi @Lemonmeth !
Well...the development activities are "on pause".

There are a lot of other solutions available, mostly done as a build-in feature in the slicer software.

I think the demand of such plugin is not so high....and I personally used such feature only 2-3 times the last years.

Maybe I will continue during X-Mas time, but currently I work (with high pressure) on my "Job-History" and "Spool-Manager"-Plugins.

So, I am sorry!

No problem at all! Ill get it working in different slicer :slight_smile: thanks for your time anyways!

Hello, hello, I installed your plugin on octoprint(0.17), and then octoprint started working badly(I couldn't open the configuration page), I had to flash octoprint, please fix the bug (:

Hi @pipepuntocom,
as mentioned before "Well...the development activities are "on pause"."
Also, there is no release of the PauseAt-Plugin. You installed a "work in progress" version.
Advice: Uninstall the plugin and use the slicer software to include pause-gcode commands.